Log in or register to post comments

updating the sdk

May 28, 2013 - 12:08am #1

Hi , I have the same problem which is indicated in this post (problem with validating in xcode) : https://developer.vuforia.com/forum/qcar-api/validation-vuforia-sdk-based-app-applestore-failed

I downloaded 2.0.32 and installed it on my imac and now I have a unity package . I just imported the new package but I'm still getting the error . since it's very difficult for me to recreate the project , I wanted to know what's the best way to update the sdk in your project , does just importing the new package enough or I should do something else ?

thanks

updating the sdk

June 24, 2013 - 2:37am #20

Great to hear, and thanks for the update.

N

updating the sdk

June 22, 2013 - 8:45am #19

Yeah , thanks . I updated my unity to 4 and my xcode to 4.6 and I successfully validated my app :)

thanks agian so much for your great support and help . 

 

updating the sdk

June 18, 2013 - 3:09am #18

Sounds like you might need to reinstall Unity.

N

updating the sdk

June 17, 2013 - 4:07pm #17

it seems it's not vuforia , I built a simple project without any vuforia code and tried to validat it and I'm still getting the same errors  . and as I mentioned it seems libiPhone-lib.a is causing the errors .

updating the sdk

June 17, 2013 - 3:09pm #16

Thanks , if I check the date of libQCAR.a in my unity project folder in Assets/Plugins/iOS/libQCAR.a it shows 4/9/13 4:38 PM . and if I check it in my build folder it shows today .  and I also noticed that when I open my built project in xcode , in Libraries folder the "Libraries/libQCAR.a" and "Libraries/libQCARUnityPlayer.a" are  shown in red (I guess means missing) . 

I copied libQCAR.a  , libQCARUnityPlayer.a and QCARUnityPlayer.h to my Libraries folder of my built folder . but again if I try to validate my project I still get the same errors . 

 

I searched for "uniqueIdentifier" as this post suggests : http://stackoverflow.com/questions/16767396/uniqueidentifier-find-in-xcodeproj-how-to-remove-it

and it returned these files : Mono.Security.dll.s , mscorlib.dll.s , RegisterMonoModules.cpp , UnityEngine.dll.s

updating the sdk

June 17, 2013 - 3:03am #15

Reveal in Finder, then look at the date.

Also the XCode log should display it.

N

updating the sdk

June 14, 2013 - 6:43am #14

Thanks , but how do I check the version of this file?

updating the sdk

June 14, 2013 - 2:53am #13

I cannot reiterate enough that this issue is fixed in the latest 2.0.32 release, so I can only think that somehow your project is picking up the incorrect files.

Please can you check the version of libQCAR.a which should say 9 April 2013 ?  

You can check this within the Unity/Assets/Plugins/iOS directory and also the generated xcode project. 

 

thanks

Nalin

updating the sdk

June 13, 2013 - 11:41pm #12

I tried again with a new project and I downloaded 2.302 again but I'm still getting the errors . I followed this post :
http://stackoverflow.com/questions/16489079/apps-are-not-permitted-to-access-the-udid-and-must-not-use-the-uniqueidentifier
and tried to trace where's this error come from with "find . | grep -v .svn | grep "\.a" | grep -v "\.app" | xargs grep uniqueIdentifier" in terminal .
it showed that "Binary file ./Libraries/libiPhone-lib.a matches" . does it show that something is wrong with my xcode or can I just replace this file ?
thanks

updating the sdk

June 11, 2013 - 1:54am #11

I'm sorry for you...

Upgrading to 2.0.32 (previously deleting all the QCAR assets from my scene!) solved it!

Are you sure you didn't download the 2.0.31, because in the "resources" page of the Vuforia site you still get that 2.0.31 buggy version...

the working vers. is here:

https://developer.vuforia.com/resources/sdk/unity

 

Ciao!

updating the sdk

June 10, 2013 - 1:21pm #10

unfortunately I haven't solved it yet and I'm still getting the error . I'll post if there was any progress .
I don't get what's wrong !

updating the sdk

June 10, 2013 - 3:27am #9

Unity/XCode version does not matter.

The latest version definitely fixes the problem so not sure why you are seeing this issue.

 

N

updating the sdk

June 9, 2013 - 11:03pm #8

Did you solved the problem?

updating the sdk

June 6, 2013 - 4:02pm #7

I created a new project and built a simple AR app with  just a cube with sdk version 2.032  . I tried to validate it and I'm still getting the same errors . does unity or xcode version matter in this case?

thanks

updating the sdk

May 31, 2013 - 2:05am #6

Then there is something not quite right with your project and must have remnants of the old SDK in it - most likely the library file.

You can compare the the libQCAR.a in each project to check, or alternatively start from scratch.

N

updating the sdk

May 30, 2013 - 2:04pm #5

Yes , of course I built a new xcode project after I did the changes. but again I'm getting these errors . 

updating the sdk

May 30, 2013 - 11:35am #4

Did you allow Unity to create a new XCode project after migrating to the newest extension version, by selecting Build or Build & Run from within the build settings UI?

If not, try that because the current release doesn't rely on the UDID and so won't provoke that warning.

updating the sdk

May 30, 2013 - 9:40am #3

Thanks , I followed the instructions of your link . I have my app working . but I'm still getting the errors when I try to validate my app in xcode organizer . I'm getting these errors : 

- your app contains non-public API usage . Please review the errors , correct them . and resubmit your application . 

-Apps are not permitted to access the UDID and must not use the uniqueIdentifier method of UIDevice . Please update your apps and servers to associate users with the Vendor or Advertising identifiers intoduced in iOS 6 .

-If you think this message was sent in error and that you have only used Apple-published APIs in accordance with the guidelines , send the app's nine-digit Apple ID , along with detailed information about why you believe the above APIs were incorrectly flagged , to

. For further information , visit the Technical Support Information page at http:/developer.apple.com/support/technical/ .

 

I'll appreciate if you can help me with this . 

thanks

updating the sdk

May 28, 2013 - 1:20am #2
Log in or register to post comments