Log in or register to post comments

URGENT: GALAXY Note Pro 12 and Galaxy Tab 4

June 5, 2014 - 3:50am #12

Hi,

We have a huge performance lag on those tablets.

In the application, as soon as I enable Qcar, the application start to have huge freeze.

I'm using Unity 4.3, I tried with 4.5 too, and change nothing.

It seems to be some kind of refresh issue.

One odd thing, I don't have a lag when I have the tablet pluged in USB....

Or event odder thing, if I tap the screen rappidly the camera works smoothly, as soon as I stop, it become laggy..

I need to ship the project tonight or tommorow, this is really urgent.

Any advice ?

 

Thanks

URGENT: GALAXY Note Pro 12 and Galaxy Tab 4

June 5, 2014 - 6:27am #11

Hi, 

 have you tried the Vuforia samples and have you observed any similar performance issue ?

 

URGENT: GALAXY Note Pro 12 and Galaxy Tab 4

June 5, 2014 - 7:26am #10

I tried with the ImageTarger sample, I have more luck than my project, but after enabling/disabling Qcar like 4-5 times, the application lag, or doesn't display the camera anymore.

URGENT: GALAXY Note Pro 12 and Galaxy Tab 4

June 5, 2014 - 7:51am #9

A little clue, it seams to append when I have dynamic shadow enable.

I'm in forward rendering.

Does it have to do with buffers ?

URGENT: GALAXY Note Pro 12 and Galaxy Tab 4

June 5, 2014 - 7:57am #8

How do you disable/enable QCAR in your tests ? Do you disable the QCARBehaviour component of the ARCamera, or other way ?

Just so I can reproduce this with the same steps.

URGENT: GALAXY Note Pro 12 and Galaxy Tab 4

June 5, 2014 - 8:01am #7

disable/enable QCARBehavior.

My ARCamera is always enable.

So disabling dynamic shadow seams to work better on the Galaxy tab 4, but still no luck on the Galaxy Note Pro

URGENT: GALAXY Note Pro 12 and Galaxy Tab 4

June 5, 2014 - 9:26am #6

I also tried running a sequence of QCARBehaviour disable + enable  shots on the Image Targets sample, but I did not observe any such lag...

Is it possible that your game also makes use of other "advanced" graphics effects (beyond the dynamic shadows) or maybe the scene is just populated with large / heavy graphical assets (e.g. large textures, 3D models with high polygon count, etc.) ?

 

Wondering, because what you say seems to suggest that possibly the Application is kind of getting close to the hardware limits, which might be hit sooner on the Note than on the tab 4...

 

EDIT:

this is the code snippet I have used for the test:

	void Start () {
		mQCAR = GetComponent<QCARBehaviour>();
	}

	void OnGUI()
	{
		if (mQCAR.enabled)
		{
			if (GUI.Button (new Rect(50,50,200,40), "Disable QCAR"))
			{
				mQCAR.enabled = false;
			}
		}
		else
		{
			if (GUI.Button (new Rect(50,50,200,40), "Enable QCAR"))
			{
				mQCAR.enabled = true;
			}
		}
	}

 

URGENT: GALAXY Note Pro 12 and Galaxy Tab 4

June 5, 2014 - 9:31am #5

No advanced graphic effects, except dynamic shadow.

Not really heavy in polygon or objects...

The only thing that come to my mind is something related to buffer .

By the way the Galaxy Note pro has a resolution of 2,560 x 1,600 .

Maybe the render to texture or the buffer is too heavy...

URGENT: GALAXY Note Pro 12 and Galaxy Tab 4

June 5, 2014 - 11:50am #4

Is it doing it with a new project and only the vuforia samples? 

 

Do you have any textures in the scene 2048px or larger?  That will make unity stutter on lower end devices. Also shaders, are you using a reflective shader on anything? Or a shader with more than just diffuse and normal maps? 

 

Heavy code running when your target is being tracked? 

 

 

URGENT: GALAXY Note Pro 12 and Galaxy Tab 4

June 5, 2014 - 1:04pm #3

Indeed it might be something to do with texture buffer size, particularly if you are using special rendering techniques such as forward rendering;

as Imbarns says, on a mobile device your app may easily suffer if you request large textures (and more in general any render buffer that is going to eat graphics memory and GPU resources).

Keep in mind that Vuforia renders the Video background into a texture (even if through Unity, at low-level the video texture is actually an OpenGL ES 2.0 texture), and if the camera video resolution is high, the amount of texture memory consumed can be significant.

One thing you could still try is to change the Camera Mode (see the ARCamera inspector) from MODE_DEFAULT to MODE_OPTIMIZE_SPEED (which may result in a video texture at a slightly smaller resolution) and see if this makes any difference.  

 

URGENT: GALAXY Note Pro 12 and Galaxy Tab 4

June 6, 2014 - 12:16am #2

I have only one 2048 texture for the GUI, but I displayed a lot more in another project on this tablet, so it's not that.

I have some "advanced" shader, but same thing, works on another project on this tablet

I have only very laggy scene on project with vuforia on this tablet (Galaxy Note Pro 12)

I though that forward rendering was actually the least advanced rendering technique compared to deffered who render in passes ...

I tried with MODE_OPTIMIZE_SPEED with no success

The scene run smooth until I trigger QCAR for the first time, next it's just laggy.

But not when USB is pluged-In, this is really the odd part.

- Can it come from with the android activity not being refreshed or something like that ?

As I said when I tap the screen repeatedly the camera refresh...

It's like the timeDelta of the application goes to 0 when nothing append on the screen or no inputs are enterred 

- Are you sure you're freeing all the memory when disabling the QCAR ?

- Is there a way to override the camera capture resolution ?

URGENT: GALAXY Note Pro 12 and Galaxy Tab 4

June 6, 2014 - 7:04am #1

- Can it come from with the android activity not being refreshed or something like that ?

As I said when I tap the screen repeatedly the camera refresh...

That's weird, indeed; I wonder if you could reproduce something similar using one of the Vuforia samples, as otherwise it is difficult to get an idea of the root cause of this... it could be something else in the Application code which is somewhat "interfering" with Vuforia and causing this situation, but without a simple repro-case it is hard to tell..

- Are you sure you're freeing all the memory when disabling the QCAR ?

I am not aware of memory not being released when disabling QCARBehaviour...

 

- Is there a way to override the camera capture resolution ?

You can change the camera mode, as I previously suggested (e.g. MODE_OPTIMIZE_SPEED vs. DEFAULT vs. QUALITY); this can affect the camera reolution; however you cannot override that explicitely.

 

 

Log in or register to post comments