Log in or register to post comments

UriFormatException

January 17, 2012 - 12:50am #1

I'm not able to run AR with Unity, I followed all the steps in the guide but
no drop down list of the available image targets appears

also the editor throws this error

UriFormatException: URI scheme must start with a letter and must consist of
one of alphabet, digits, '+', '-' or '.' character.
System.Uri.Parse (UriKind kind, System.String uriString)
System.Uri.ParseUri (UriKind kind)
System.Uri..ctor (System.String uriString, Boolean dontEscape)
System.Uri..ctor (System.String uriString)
System.Xml.XmlResolver.ResolveUri (System.Uri baseUri, System.String
relativeUri)
System.Xml.XmlUrlResolver.ResolveUri (System.Uri baseUri, System.String
relativeUri)
Mono.Xml2.XmlTextReader.GetStreamFromUrl (System.String url, System.String&
absoluteUriString)
Mono.Xml2.XmlTextReader..ctor (System.String url, System.Xml.XmlNameTable nt)
System.Xml.XmlTextReader..ctor (System.String url, System.Xml.XmlNameTable
nt)
System.Xml.XmlTextReader..ctor (System.String url)
ConfigParser.fileToStruct (System.String configXMLPath, .ConfigData
configData) (at Assets/Editor/QCAR/Scripts/ConfigParser.cs:53)
ConfigDataManager.ReadConfigData (System.String dataSetFilePath) (at
Assets/Editor/QCAR/Scripts/ConfigDataManager.cs:222)
ConfigDataManager.DoRead () (at
Assets/Editor/QCAR/Scripts/ConfigDataManager.cs:96)
SceneManager.InitScene () (at Assets/Editor/QCAR/Scripts/SceneManager.cs:125)
DataSetLoadEditor.OnEnable () (at
Assets/Editor/QCAR/Scripts/DataSetLoadEditor.cs:19)

I got 1.5 beta for Unity

thanks

Re: UriFormatException

January 18, 2012 - 1:03am #4

I found the solution, the problem was a space in the directory name !

Thanks for the support

Re: UriFormatException

January 17, 2012 - 7:07pm #3

Be sure to re-upload your targets to the TMS for 1.5, and download the new dataset. Import it into Unity, and use the QCAR menu "Rename 1.0.x Data Set" option to convert it for use with 1.5. If you can't see the QCAR menu at the top try saving the project.

It sounds like you might be having trouble with 1.0 as well though? In that case, make sure none of your trackables have names with contentious characters (keep them alphanumeric).

If you're still having trouble please send the config file to

and we'll take a look. Also let us know what version of Unity you are using.

- Kim

Re: UriFormatException

January 17, 2012 - 7:19am #2

I just tried the 1.0 stable but I get the same error and no trackable images will shows up in the drop down list

Log in or register to post comments