Log in or register to post comments

Video on Plane update keyframe image?

July 15, 2012 - 2:18pm #1

Hi, I'm trying to cycle through a few different images on the keyframe image that appears before touching the plane to activate the video playback.  I can see that the images are cycling in the small preview thumbnail associated with the material, but it's not updating the image in the editor.  Is there a separate editor script controlling this?  I cant seem to find one.

Thanks!

Video on Plane update keyframe image?

July 17, 2012 - 2:33am #5

Great that this is sorted :)

It will not work in the editor because you are setting it at run-time, plus Vuforia is not set up to "play" within the editor environment i.e. it has to be running on the device partly because 1) it has a camera and 2) it is a mobile solution, not a PC/Mac/Web one.

Hope this makes sense.

N

Video on Plane update keyframe image?

July 16, 2012 - 11:18am #4

Yes it seems that for the images to cycle correctly I had to keep updating the keyframe image in something like a coroutine or update loop.  It works now on the device, but just not in the editor.

Video on Plane update keyframe image?

July 16, 2012 - 11:13am #3

video on texture is great. thanks for the feature!

 

Video on Plane update keyframe image?

July 16, 2012 - 7:26am #2

Hi patch24

I am assuming you are trying to change/animate this frame before the video plays right?

So the Inspector panel on the video exposes the Keyframe texture, along with Play, Busy and Error textures, and this is controlled by the VideoPlayBackBehaviour Script.  Nothing else touches this at run-time, though VideoPlaybackEditor will affect it at design time.

So in theory you should be able to change this in the update loop and it should be visible accordingly.  Is this not what happens?

N

Log in or register to post comments