Topic locked

video playback after upgrade exception

January 14, 2014 - 12:52am #1

Hi,

 

after upgradign project to vuforia 2.8 I'm getting this error when video playback is started.

Can't figure out how to fix it.

Does anyone know what to do with this?

/QCARPlayerNativeActivity/libs/VuforiaMedia.jar  is included in project.

Thnaks

 

01-14 09:50:05.354: I/Unity(22747): AndroidJavaException: java.lang.UnsatisfiedLinkError: Native method not found: com.qualcomm.VuforiaMedia.VideoPlayerHelper.initMediaTexture:()I
01-14 09:50:05.354: I/Unity(22747):   at UnityEngine.AndroidJNISafe.CheckException () [0x00000] in <filename unknown>:0 
01-14 09:50:05.354: I/Unity(22747):   at UnityEngine.AndroidJNISafe.CallBooleanMethod (IntPtr obj, IntPtr methodID, UnityEngine.jvalue[] args) [0x00000] in <filename unknown>:0 
01-14 09:50:05.354: I/Unity(22747):   at UnityEngine.AndroidJavaObject._Call[Boolean] (System.String methodName, System.Object[] args) [0x00000] in <filename unknown>:0 
01-14 09:50:05.354: I/Unity(22747):   at UnityEngine.AndroidJavaObject.Call[Boolean] (System.String methodName, System.Object[] args) [0x00000] in <filename unknown>:0 
01-14 09:50:05.354: I/Unity(22747):   at VideoPlayerHelper.videoPlayerLoad (System.String filename, Int32 requestType, Boolean playOnTextureImmediately, Single seekPosition) [0x00000] in /Users/stan/Documents/workspaceUnity/ar4/Assets/Scripts/VideoAndroid/VideoPlayerHelper.cs:320 
01-14 09:50:05.354: I/Unity(22747):   at VideoPlayerHelper.Load (System.String filename, MediaType requestedType, Boolean playOnTextureImmediately, Single seekPosition) [0x000
 

video playback after upgrade exception

February 26, 2014 - 12:36am #5

Hi,

Yep, there is nothing wrong at vuforia. In my case I did follow upgrade procedure and also cleared vuforia files in unity project before importing new files but I must have had missed something somewhere. Just repeated all and also probably cleaned exported eclipse project or recreated it can't remember now.

In any case it has gone then.

S.

 

video playback after upgrade exception

February 25, 2014 - 11:33am #4

Has there been any update on this issue?

 

I/Unity   (14650): Exception: java.lang.UnsatisfiedLinkError: Native method not found: com.qualcomm.VuforiaMedia.VideoPlayerHelper.initMediaTexture:()I
I/Unity   (14650):   at UnityEngine.AndroidJNISafe.CheckException () [0x00000] in <filename unknown>:0 
I/Unity   (14650):   at UnityEngine.AndroidJNISafe.CallBooleanMethod (IntPtr obj, IntPtr methodID, UnityEngine.jvalue[] args) [0x00000] in <filename unknown>:0 
I/Unity   (14650):   at UnityEngine.AndroidJavaObject._Call[Boolean] (System.String methodName, System.Object[] args) [0x00000] in <filename unknown>:0 
I/Unity   (14650):   at UnityEngine.AndroidJavaObject.Call[Boolean] (System.String methodName, System.Object[] args) [0x00000] in <filename unknown>:0 
I/Unity   (14650):   at VideoPlayerHelper.videoPlayerLoad (System.String filename, Int32 requestType, Boolean playOnTextureImmediately, Single seekPosition) [0x00000] in <filename unknown>:0 
I/Unity   (14650):   at VideoPlayerHelper.Load (System.String filename, MediaType requestedType, Boolean playOnTextureImmediately, Single seekPosition) [0x00000] in <filename unknown>:0 
I/Unity   (14650):   at VideoPlaybackBehaviour.OnRenderObject () [0x00000]

 

Update:

 I reimported libVuforiaMedia.so and the exception went away, but there are still no results on screen. Thought maybe I had some conflicting files now.

Opened new project and dumped both vuforia and the vuforiaMedia packages, and it works as is. I'll keep poking at changes until i fix my personal issue, and maybe it can help you too when I'm done.

 

video playback after upgrade exception

January 14, 2014 - 5:28am #3

Hi,

yes I followed this page when migrating.

I do not see there any special info about video play plugin.

S.

video playback after upgrade exception

January 14, 2014 - 12:55am #2

Have you checked the steps in the migration guide:

https://developer.vuforia.com/resources/dev-guide/migrating-your-unity-project

?

 

Topic locked