Log in or register to post comments

Video Playback in Play Mode - Unity

August 24, 2016 - 10:56pm #1

Hi, 

I wanted to play my video in the Play Mode of the unity when marker reads the target. I tried everything and searched on the various forums as well, it doesn't seem anyone has the answer. I am using Unity 5.4 with Vuforia 6. The sample provided in the downloads here has functionality to tap and play video. The  video shows 'x' mark which means error in playing video when I am in play mode. People in the forums said try to use autoplay enabled from the script, but it doesn't help either, others claiming that we need a 'VideoPlaybackController' script to use and play video in Unity Play Mode. Please someone provide with the script or solution regarding video playback in play mode. Thanks.

AttachmentSize
Image icon Error in Play Mode547.11 KB

Video Playback in Play Mode - Unity

February 23, 2018 - 11:52am #17

Hello Vuforia Support,

I've been trying to change the image target in the "Fissure" core sample files and this seems to break the AR.

What steps are necessary to change out the image target in the "Fissure" example? We are able to edit the video that is being played. We've addded our own key, database and activated, change the target to a new image but no luck, it doesnt work.

Are there any other adjustments to be made or other things in the core files that could be affecting this?

Thanks!

Video Playback in Play Mode - Unity

February 19, 2018 - 10:17am #16

Hello thejiay,

Videoplayback is available in Unity via the Core Samples. Please see the Fissure Target in the Image Target scene within this sample.

Thanks,

Vuforia Support

Video Playback in Play Mode - Unity

February 18, 2018 - 7:39pm #15

I need to video playback please.

Video Playback in Play Mode - Unity

October 10, 2017 - 5:06pm #14

Hello,

The Advanced Topics samples for Unity will be available on the Unity Asset Store very soon for Unity 2017.2 with Vuforia 6.5. I will make a post when they are released.

Thanks,

-Vuforia Support

advanced topic for unity

October 3, 2017 - 9:17am #13

can i know when will the advanced topics for unity will be released.

Video Playback in Play Mode - Unity

September 13, 2017 - 1:08am #12

I am facing same problem. Can anyone please help?

AttachmentSize
Image icon videoplayback.png53.17 KB

Video Playback in Play Mode - Unity

September 11, 2017 - 7:05am #11

I need to download those packages too. 

I don't know why but its listed as 'Coming Soon', under 'Advanced Topics' on this page - https://developer.vuforia.com/downloads/samples

Video Playback in Play Mode - Unity

September 7, 2017 - 9:23pm #10

asharrahmad wrote:

see this https://www.youtube.com/watch?v=mBqD0l0hzBc&t=266s

 

I saw this video but could not find to download both packages that he/she used on the project, can someone please provide me the links to download this packages??

 

Thanks

Video Playback in Play Mode - Unity

September 7, 2017 - 9:17pm #9

Hello friends, 

 

I cannot find the unity package for the "Advanced topics" on the samples page.

 

I need to do a video start playng on an object targeted by the camera of my phone.

I already can do the camera recognize the image target and show the "cube".

 

All the examples that I find use this "Advanced topics" sample, to include the video playback, but I cannot find.

Can someone help me?

 

*Sorry for my bad english, not my native language.

 

Thanks for the help.

Video Playback in Play Mode - Unity

August 25, 2017 - 11:58am #8

Video Playback in Play Mode - Unity

February 27, 2017 - 2:20am #7

I'm facing same problem, the major issue is that to double check I have to build and deploy everytime which is time consuming.

Video Playback in Play Mode - Unity

January 10, 2017 - 7:56am #6

Hello,



I have some issues with the video playback, too.

I followed this tutorial https://developer.vuforia.com/forum/faq/unity-how-do-i-create-simple-videoplayback-app

step by step.

But when I want to try it e.g. with my computer webcam, the camera recognizes the image on a piece of paper which I am holding in front of my camera. But instead of playing the video, the program just overlays my original image with the same "virtual image" with an x-icon on top of it.



Then I tried it on my Android phone. I had problems conecting the device to my computer to use the "unity remote 5 app" so I saved an file, which I dragged into my phone and installed the app manually. Same problem here: The app recognizes the image (and follows it when moving around), but instead of playing the video, the virtual image just "sits" on the paper-image and has an x-icon on it.

I downloaded unitypackage about 3 weeks ago, so I think it´s still the latest version.



Please, can you give me any advice how to fix my problem?

I appreciate any comment :)



Thank you and have a great day!

Emilia

Video Playback in Play Mode - Unity

August 26, 2016 - 10:39pm #5

Hi Jürgen,

I had issues like you had of crashing unity a lot of times. I believe its with the 64-bit version of the Unity which causing it. However, I did managed to successfully run the videoplayback in the 64-bit with struggling a lot with the crashes and errors in unity-64bit. But if you're doing a good amount of R&D I suggest to try unity32-bit only. A lot of times the video won't play, actually It never did for me, so, Yeah, You might wanna put in a IOS or Android device to check for your application with the whole Augmented Reality Videoplayback thing. Here what I will do, If I were you :

1. I will use reinstall 32bit unity 5.4 or above specifically, because I will be using Vuforia 6 which is the latest version, and so as to cope with versions and with the bugs and issues which I don't want to face again. 

2. I will probably check with a ready made tutorial to see if it's me, missing some important part such as Licensing my app, properly using target, and have I activated the data sets properly or not. And also just simply try to build a ready made tutorial so as to check my software and plugins whether they  are running perfectly or not. 

*You might wanna checkout this man's work he used vuforia in a very efficient way with a good tutorial as well : https://www.ourtechart.com/augmented-reality/tutorial/augmented-reality-video-playback/

(Try to use the latest versions to avoid crashes and bugs)

*Here's a ready made tutorial to check your software's and plugins are running perfectly fine or not : https://docs.google.com/uc?authuser=0&id=0BygvzTqnzm_wd01NNUp4eldhMGs&export=download

 

Regards.

 

Video Playback in Play Mode - Unity

August 25, 2016 - 10:01pm #4

Hey,

Thanks for the reply and being a mate. Actually I got my answer very well now. But yeah, It is certainly a Unity's problem. I tested the build in my phone, and it is perfectly running fine, however I had issues while autoplaying it, having the autoplay option ticked in the inspector. It is not Vuforia again, I am certainly missing some code I guess. Also I got my precious answer in the Unity's forums, that I shouldn't have used Unity 64-Bit to test Vuforia's samples, it doesn't compatible enough to play lot of things in Play Mode while using Vuforia. Some people says Vuforia is good and less Erroneous with Unity 32-bit. So, In short I should re-install Unity again. Thanks. 

Video Playback in Play Mode - Unity

August 25, 2016 - 4:23am #3

Hello!

 

Unfortantly you can't play videos in Unitys "playmate". This is Unitys problem, not vuforia.

If you get the X up normally means that it works. However, to really know you need to export it to a phone and try it there!

If you got the Vuforia video Playback folder in your Unity project you should be good to go!

 

Video Playback in Play Mode - Unity

August 25, 2016 - 2:48am #2

Hi,

I have the same problem :-((

Sometimes the Unity 5.4.0f3-HTP (64-bit) crashed by using the VideoPlayback-6-0-112.unitypackage. Also with the VideoPlayback-5-5-9.unitypackage Version with Unity 5.3.5 (64-bit & 32-bit).

Since the 28th of june I try to run this application and it don´t work well.

Sorry that I have no solution for this issue.

Regards from Germany

Jürgen

 

 

AttachmentSize
Image icon Error-vuforia.jpg43.1 KB
Log in or register to post comments