Log in or register to post comments

in VideoPlayback, Tap does not work

February 28, 2014 - 9:53pm #1
I used VideoPlayback 2-8-9. When captured by the camera target, Video is played in the Auto mode. 
 
But I can not to stop playback. Do not stop even if is clicked, the icon does not react. 
 
Do you know why? 
 
 
1.I create NewProject in Uity 4.2.2 
 
2.download vuforia-sampleapps-unity-2-8-9, double-click the Videoplayback-2-8-9.unitypackage. And I have imported. 
 
3.Maincamera deleted. 
 
4.Add ARCamera. (Assets folder - Qualcomm Augmented Reality folder - Prefabs-ARCamera) 
  And Load Data Set ~ check (Data Set Load Behavior (Script)) 
  Check the Active 
 
5.Add ImageTarget. (Assets folder - Qualcomm Augmented Reality folder - Prefabs-ImageTarget) 
  Change to Trackable Event Handler.cs the Default Trackable Event Handler 
 
6.Add Derectional Light. (GameObject - Create Other - Derectional Light)

7.Place under the ImageTarget the Video.prefab. (Assets - Vuforia Video Playback - Prefabs) 

8.Add video to play Path of (Script) Video Playback Behaviour in the Inspector of Video.prefab 
 
9.Check the Auto Play
 
10.Build and Settings
 Select Android in the Build and Settings, Run. 
 
 
Version of Android mobile 4.0.1. Video will start when you load a target in the AR camera. 
However, tap does not work. 
When the 2-6-7 version, I had the VideoPlaybackController.cs does not have it in 2-8 -9. 
How can I do this?

 

Unity Ver.4.2.2
Videoplayback2-8-9.unitypackage
Android4.0.1

 

 

in VideoPlayback, Tap does not work

July 18, 2016 - 9:29am #10

hi

im using the lates sample set and unity 5 and i have the same problem.

the play button tapping doesnt work. 

is there anything i should do?

in VideoPlayback, Tap does not work

March 4, 2014 - 3:01am #9

A forthcoming release will make it easier to eliminate the About screen.

Meanwhile I posted up a workaround to this here, which you have already seen

https://developer.vuforia.com/forum/unity-3-extension-technical-discussion/video-playback-about-intro-page#comment-2038609

...albeit with one minor side effect at the moment.  The only other thing I can suggest at the moment is to debug it on the device and find out what is happening.

 

HTH

N

in VideoPlayback, Tap does not work

March 3, 2014 - 11:26pm #8

hi kyo241.

I think you misunderstood or probably I'm the one that misunderstood you.

The problem is that I cant get rid of the About and Splash screen without breaking the playback function that came within the Sample package. There are other thread about it as well. Probly they already found the solution or maybe not using it at all.

in VideoPlayback, Tap does not work

March 3, 2014 - 5:48pm #7
I do not understand. 
 
I think that's VideoPlayback2-8-9 that's a sample of the latest version. 
What is the difference? 
 
I do not understand that the latest version can not be supported.
Will you of us to support that it is a sample of what version? 
 
Version of Unity is old? 
 
However, VideoPlayback app does not play correctly in Unity 4.3. 
 
That means, 
Videoplayback2-8-9 and Unity4.2 combination is best.
 
I do not understand it's not longer be supported.
 
thanks.
 

in VideoPlayback, Tap does not work

March 3, 2014 - 1:11pm #6

NalinS wrote:

Sorry, but we are no longer supporting previous versions of the SDK and Samples.

thanks

N

Thats understandable and fair enough. But could you show us a way to disable the 'About' and 'Splash' screen without breaking the other functionality? 

Hope someone from the Dev can help on this.

Thanks.

in VideoPlayback, Tap does not work

March 3, 2014 - 3:02am #5

Sorry, but we are no longer supporting previous versions of the SDK and Samples.

thanks

N

in VideoPlayback, Tap does not work

March 2, 2014 - 3:15pm #4
In this sample application, to version 2-6 had been enclosed and "VideoPlaybackController.cs". 
 
Why the script do you have been deleted Become a Version 2-8? 
 
VideoPlaybackAppManager.cs 
VideoplaybackUIEventHandler.cs 
VideoPlaybackUIView.cs 
 
Scripts of these three have been made new. I believe this script if placed correctly, this problem is not whether to resolve. 
 
Can you tell me where to place them?

in VideoPlayback, Tap does not work

March 1, 2014 - 10:01am #3

AlessandroB wrote:

Tap to start/stop the video will not work just because the tap control is part of the sample code, (it is not part of the Video prefab); have a look at the Scene Manager and all the UI related classes in the sample. 

Then the script might look a bit redundant, which provide 3 slots for the icon and not doing anything unless we use the sample scene that must include Scene Manager. One might just use movie to texture, correct me it I'm wrong.

I'm not a programmer by any means. I tried to disable the 'splash' and 'about' screen but still it doesnt work. When I manage to get rid of it, it break the script. I have to double tap to play the video in full screen and exit to enable single tap to play the movie.

I wonder if the dev/admin has lost their interest in this 'issue' cause already posted in 3 different thread but never had any reply.

in VideoPlayback, Tap does not work

February 28, 2014 - 11:47pm #2

Tap to start/stop the video will not work just because the tap control is part of the sample code, (it is not part of the Video prefab); have a look at the Scene Manager and all the UI related classes in the sample. 

Log in or register to post comments