Log in or register to post comments

Vuforia 1-5-10 - Unity 3.4.0.f5 - Samsun GSII - 4.0.3 Blackscreen

August 8, 2012 - 1:51am #1

I tried almost evrything i have no idea what to do anymore.

Ok i followed the basic "Compiling simple project" steps from the website but in the end when i convert to apk and install it on my phone it keeps giving a blackscreen and a message "TestProject has stopped" and it shutsdown the app.

The project used to run in qcar-unity-android 1-0-6 on android 2.3 with no problems.

But when i open that project in 4.0.3 (icecream) its gives a error camera not found so i updated the old qcar library to 1.5.10 but its doing even less then the old version. Also started a complete new project with 1.5.10 but still black screen.

Ive downloaded and cracked the newest version of unity just to try but also blackscreen.

Newest SDK still blackscreen.

What am i doing wrong ?!

Vuforia 1-5-10 - Unity 3.4.0.f5 - Samsun GSII - 4.0.3

August 26, 2012 - 11:42am #6

Thanks for the follow up. This is a good example of what it's smart to maintain known-good versions of your Unity installation when upgrading.

Vuforia 1-5-10 - Unity 3.4.0.f5 - Samsun GSII - 4.0.3

August 22, 2012 - 3:33am #5

Ok i finnaly got it running if you have an updated Samsung GS2 with 4.0.3 you need atleast.

Unity 3.5.5f3 to get it running despite what the manual says so hope this helps someone.

Vuforia 1-5-10 - Unity 3.4.0.f5 - Samsun GSII - 4.0.3

August 13, 2012 - 3:01am #4

I haven't tried 3.5.4 yet now testing with 3.5.3f3, the basic image target sample app is what im testing with a.t.m i followed the example to the letter but still to no avail.
The trouble only started since i update my phone (GT-I9100) to: 4.0.3 the old libraray 1.0.6 was working fine with 2.3 on the same phone.

I noticed that when i build it in the latest Unity version it doesn't crash, but it shows the Unity logo atleast and then shutsdown.
So its a bit diffrent from a blackscreen :P 

Vuforia 1-5-10 - Unity 3.4.0.f5 -

August 9, 2012 - 3:59pm #3

Hello,

Have you updated to Unity 3.5.4 ? Also please try running the ImageTargets sample app and let us know if that runs on your device. Can you also post the model name of your device, found in Settings -> About Phone -> Model .

Thank you,

-Peter

Vuforia 1-5-10 - Unity 3.4.0.f5

August 8, 2012 - 4:26pm #2

Can you post your build and run log?

If you don't have Eclipse installed, you can do this from the command line by calling ADB as such..

adb logcat -d > logcat.txt

That will write the log to a file.

https://sites.google.com/site/androidhowto/how-to-1/save-logcat-to-a-text-file

 

Log in or register to post comments