Log in or register to post comments

Vuforia 6 and Unity 5.3.6p2+

September 6, 2016 - 3:41am #1

Is there an issue with compatibility with V6 and Unity regarding canvas display?  I recall this used to happen in earlier versions of new Vuforia releases.

 

I have  an AR setup with a canvas that if trigger is lost displays a message and if found displays controls.  This works fine repeatedly in the Editor, but as soon as I build to Android the canvas content is no longer displayed.

I run in editor immediately after build and the canvas parts are set active but do not display, the same on device.

If I close Unity open again and run the canvas works as expected until I build to device?

I have tried 5.3.6p1, 5.3.6p2 and 5.4.0p1 and all do the same thing?

Vuforia 6 and Unity 5.3.6p2+

September 7, 2016 - 4:00am #3

Ah, no they don't and in fact I found previous apps that did work no longer do so!  

I reverted to V5 and still the problem persisted but had an idea...

To save space I moved my applications that take up huge space (Unity) to my 128GB USB3 drive and on a number of occasions overnight the power went off and upone reboot am told disk not ejected properly....

Then though, could it be possible as I had Unity versions open they are corrupt?

Uninstalled all Unity versions and reinstalled again.....problem resolved!

So defo looks like a corrupted Unity installation rather than Vuforia....happy again :-)

 

Thanks

 

Vuforia 6 and Unity 5.3.6p2+

September 6, 2016 - 2:33pm #2

Do the UI Canvas' in our sample apps work okay? You may want to compare your settings to those.

Log in or register to post comments