Log in or register to post comments

Vuforia Hangs Camera (and app)

January 7, 2013 - 12:52pm #1

I have a major problem. This doesnt happen too often but when it does it creates a very bad user experience.

When I use vuforia plugin for unity usually everything works fine. Sometimes though My camera tends to hang. This is espeically noticable when i disable and enable QCARBehaviour several times in sequence. (I enable qcar, scan a tag, click on model that shows up, disable qcarBehaviour, play around on this camera, then return to qcar (enabling it again), several times) If it always happened then i know it is something with my code but it happens sporadically. SOmetimes it will happen 3 or 4 times in a row where the camera will hang and i will have to restart the whole tablet because I cannot retrieve the camera again, othertimes it will not happen for 20 or so repetitions before happening again.

I dont know if it is something with how many image targets I use or something else but it does get annoying when I have tried to fix all bad code and it still happens. 

Any help or info would be much appreciated.

I am seeing this on the

January 8, 2013 - 6:03am #3

I am seeing this on the Galaxy Tab 10.1. This is the only tablet I have tried this on so far, but my Galaxy Nexus phone does not seem to have the problem. Just a Seg. Fault after running for a while, which I know is usually from the overheating as I have 350 targets.

I am toggling this sometimes several times a minute and I get no logcat erros unless i try to tap the screen, then i get the ANR response. If i leave it for like a min or two it starts running again but it is not something that this app should have (the 1 or two minute hang).

Which tablet are you seeing

January 7, 2013 - 1:31pm #2

Which tablet are you seeing this on, and have you seen the same behavior on other devices? Also how quickly are you toggling the QCARBehaviour? 

Are you seeing any errors or warnings in the runtime log?

 

Log in or register to post comments