Log in or register to post comments

"Vuforia Initialization Error" when switching scene in Unity

January 5, 2016 - 4:00am #1

Hi guys, 

Pretty noob at programming so I apologize in advance if my question sounds silly.

Direct to the point:

1. When i switch from scene "0" (Non-AR menu scene) to scene "1" (AR gameplay Scene) I get the following screen as shown in the attached image.

2. Scene "0" is a VR scene using Google Cardboard (not Vuforia Digital Eyewear) and it works fine for the most part. Scene "1" uses Vuforia Digital Eyewear.

3. In my Unity (version 5.3.1f1) play mode, the scene transitions smoothly and behaves like how i expected it to, so I don't think it's an issue with my code.

Can somebody help me out here? I have tried combing through my codes for logical errors or other reasons why my phone just wont load the AR scene, any help will be much appreciated, thank you very much! :)

P/S: If the following information is helpful:
- my phone is a Xiao Mi 3 running on android version 4.4.4

- Unity version 5.3.1f1

- Used on Google Cardboard native SDK, and Vuforia Core Samples

AttachmentSize
Image icon Screenshot_2016-01-05-13-51-13.png16.27 KB

"Vuforia Initialization Error" when switching scene in Unity

January 18, 2016 - 6:53pm #3

Thanks for the reply Alchemycs!

I got mine to work by changing the AndroidManifest.xml file according to vuforia's instructions, careless of me not to read the instructions beforehand haha.
here is the link if anybody ever encounters the same problem like i did: https://developer.vuforia.com/library/articles/Solution/Integrating-Cardboard-SDK-050

"Vuforia Initialization Error" when switching scene in Unity

January 8, 2016 - 1:24am #2

 

I've been pulling my hair out for the last few hours with something similar, here is my situation with what I have found:

(TL;DR : Import the Vuforia plugin before the Cardboard plugin)

My setup and problem:

  1. I had an Andorid app made with Unity 5.1 with two scenes: 1st uses cardboard VR, 2nd use vuforia AR. Everything working as expected
  2. Migrated project to Unity to 5.2.4 (5.3 has too many bugs in other projects)
  3. Migrated Cardboard to 0.5.2
  4. Migrated Vuforia to 5.0.10
  5. Began pulling hair out because of the same error you have...

 

Troubleshooting:

  1. Built a new unity project with vuforia plugin and the same image dataset as my original project and a cube over the image when detected, everything worked fine.
  2. Then imported the Cardboard SDK plugin and everything still worked
  3. Created a completely new project
  4. Imported Cardboard SDK plugin
  5. Imported the vuforia plugin and the same image dataset as my original project and a cube over the image when detected: same problem as my original project (the same as you have)

Fixing my original project:

  1. Deleted the 'Plugins' folder
  2. Imported the Vuforia plugin FIRST
  3. Imported the Cardboard plugin SECOND
  4. Both scenes work as expected without the original error in the AR scene (same as you are getting)

So it appears the order matters!

Caveat:

I found the following caveat with my earlier project and appears to be true with the final setup I have described here, but it works at least. The caveat is that when you go into the Google Cardboard app on your device and go to the "My Library" tab it will not detect your app as a google cardboard app. This could be a problem with the app store in case someone is trying to search for an Cardboard app.

I hope this helps you and anyone else who may come across this!

If anyone figures out how to fix up that final caveat, I would love to know!

P.S. If your interested, this is the project I'm working on: http://burningneuron.itch.io/rift-defence

Log in or register to post comments