Log in or register to post comments

Vuforia not working in iOS with Unity4.5.1

July 4, 2014 - 11:23am #1

Hello!

I just want to say that vuforia 3.0.6 is not working in iOS with Unity 4.5. I opened the same project with Unity 4.3.4 and It works. Also with this new version of Unity I have to add Security.framework and Game Center to my App (in xCode for iOS).

Too many problems when using new versions of Unity...

 

Vuforia not working in iOS with Unity4.5.1

July 4, 2014 - 10:46pm #6

mickbanks, the issue described in this thread is a different one.

 

Vuforia not working in iOS with Unity4.5.1

July 4, 2014 - 7:49pm #5

  Quote ..  "  FOr the sake of making a quick test, I just tried importing a sample in Unity 4.5.1 and it works like a charm, without issues. "

Did you try creating a Primitive & seeing if it loads during runtime ... ?? 

 

The Sample scene loads fine  but any other object won't display in Play mode.. ( only  the TeaPots display )  

:(

 

Michael

Vuforia not working in iOS with Unity4.5.1

July 4, 2014 - 7:43pm #4

Hi necronic007,

I've deleted all other Unity versions  from my computer.  eg.   4.2 - 4.3   

Created a new Project & loaded up  Vuforia 3   +  the sample scene  " ImageTarget " ( the latest sample scenes from the Qualcomm site ) 

 

I'm still getting  the same problem.   

The scene plays & I can see the TeaPot  in play mode when the MacBook Pro's  camera  targets the image target.

 

I really appreciate your feedback on this problem

 

Michael  

Vuforia not working in iOS with Unity4.5.1

July 4, 2014 - 5:39pm #3

Not sure others are facing this problem... but I have loaded the sample scene "target image "  from V3.06  &  the Tea Pots are visible when in play mode... but any other objects placed in the scene & parented to a target image  will turn render mesh off... everytime  the AR camera targets the target image. 

anyone else have this issue runing latested  Unity 4.5 Pro.

Vuforia not working in iOS with Unity4.5.1

July 4, 2014 - 12:17pm #2

Vuforia has been extensively tested on 4.3and 4.5 and it supports both those versions (including the latest 4.5.1). FOr the sake of making a quick test, I just tried importing a sample in Unity 4.5.1 and it works like a charm, without issues.

Maybe try opening a Vuforia sample in Unity 4.5, or create a a fresh new empty project, drag a couple of Vuforia prefabs of your choice into the scene (e.g. an ARCamera and an Image Target for instance), build and run. This should just work, provided that you have correctly installed Vuforia and Unity.

If you have moved an your existing project from Unity 4.3 to Unity 4.5, there might be an issue with your specific project in doing such migration.

Or, if you have migrated an older project from a previous version of Vuforia to the latest 3.0.6, make sure to check the migration guide:

https://developer.vuforia.com/resources/dev-guide/migrating-your-unity-project

 

Note: if you are building the Unity project in XCode 5.1, check this for an overview of the correct project settings:

https://developer.vuforia.com/forum/ios/ios-compiling-vuforia-project-xcode-51

 

 

 

Log in or register to post comments