Log in or register to post comments

warning CS0618: `Vuforia.MarkerBehaviour' is obsolete

August 11, 2016 - 6:44pm #1

I've just installed Unity 5.4.0 (64bit) and Vuforia 6 and am getting the following Warning in the Console when I Build and Run:

Assets/Vuforia/Scripts/Internal/VuforiaBehaviourComponentFactory.cs(42,44): warning CS0618: `Vuforia.MarkerBehaviour' is obsolete: `This class is deprecated. The same functionality is provided by using a rectangular VuMark.'

What must I do to resolve it?

I'm new to Unity and Vuforia 

thanks

 

warning CS0618: `Vuforia.MarkerBehaviour' is obsolete

August 25, 2016 - 12:13pm #5

Is there any way to disable or suppress this warning? I am not using FrameMarkers in my project and would prefer to not constantly see this notification.

warning CS0618: `Vuforia.MarkerBehaviour' is obsolete

August 18, 2016 - 3:40pm #4

Notice the warning is coming from Vuforia's SDK though. Vuforia deprecated that class but still uses it internally in their latest SDK. Anyone upgrading to the latest Unity Vuforia SDK will see this warning message.

warning CS0618: `Vuforia.MarkerBehaviour' is obsolete

August 15, 2016 - 9:49pm #3

ok thanks

warning CS0618: `Vuforia.MarkerBehaviour' is obsolete

August 12, 2016 - 3:03pm #2

Hello,

This warning message is a notification to our development community that the FrameMarkers feature has been marked as deprecated in Vuforia 6.

https://library.vuforia.com/articles/Training/Frame-Markers-Guide

Our newest feature, VuMarks, provides a more robust and customizible fiducial-type marker solution.

https://library.vuforia.com/articles/Training/VuMark

Hope this clarifies it is a notification and not an actual error.

Thanks

Log in or register to post comments