Log in or register to post comments

Web Cam Behaviour problems in Unity 5 32 bit

March 19, 2015 - 5:41pm #1

Hi there,

I am using Unity 5 32 bit, and trying to get play mode working to display a webcam, but it will only display a full black input.

When the game is not running, I get the following errors on the Web Cam Behaviour component:

- An error occurred while trying to enable Vuforia play mode

- Webcam profile not found! Unfortunately there is no profile for your webcam model ". The default profile will be used...

 

I can build and run the game without a problem on my Android phone and the camera works properly. 

I have looked through the other threads, but most seem to indicate that I should switch to 32 bit Unity 5 (which I have already done), or seem to have other issues (such as a clash with Oculus drivers or other plugins). 

Anything that I could try to fix this issue? It will be very difficult to debug the app without being able to use the webcam. 

 

Matt

Web Cam Behaviour problems in Unity 5 32 bit

August 23, 2017 - 11:41am #7

Fixed!!! Your are right man! edit the profiles.xml file

1. at line 224, remove word " (Built-in) "

     Changed it to: <webcam deviceName="FaceTime HD Camera">

2. add your WebCam device name

<webcam deviceName=" YOUR DEVICE NAME ">

        <windows>

            <!-- size of the web cam texture requested from Unity -->

            <requestedTextureWidth>640</requestedTextureWidth>

            <requestedTextureHeight>480</requestedTextureHeight>

            <!-- size of the texture Unity's web cam texture will be rescaled to -->

            <resampledTextureWidth>640</resampledTextureWidth>

            <!-- <resampledTextureHeight>480</resampledTextureHeight> -->

        </windows>

        <osx>

            <!-- size of the web cam texture requested from Unity -->

            <requestedTextureWidth>640</requestedTextureWidth>

            <requestedTextureHeight>480</requestedTextureHeight>

            <!-- size of the texture Unity's web cam texture will be rescaled to -->

            <resampledTextureWidth>640</resampledTextureWidth>

            <!-- <resampledTextureHeight>480</resampledTextureHeight> -->

        </osx>

    </webcam>

Done!

 

afnan daud

Web Cam Behaviour problems in Unity 5 32 bit

November 26, 2015 - 4:11pm #6

I also received the message "Webcam profile not found! …". Working here on a Macbook, Unity 5.1.3 p1 personal edition, Vuforia 5.0.6. 

 

I got the built-in camera working by editing the profiles.xml file. It is located at "Assets/Vuforia/Editor/WebcamProfiles/profiles.xml"

Opened this file, scrolled down, and looked for the following line (approx. line 224): 

    <webcam deviceName="FaceTime HD Camera (Built-in)">

 

Changed it to:  <webcam deviceName="FaceTime HD Camera">

Done. Camera starts. 

 

 

AttachmentSize
Image icon vufo.jpg35.57 KB

Web Cam Behaviour problems in Unity 5 32 bit

April 17, 2015 - 12:47am #5

Vuforia 4.0.105 with Unity 5.0 support (for Mac OSX 64bit and Win 32bit versions) has now been announced here:

https://developer.vuforia.com/forum/news-and-announcements/announcing-unity-50-64-bit-support-mac-os-x

Web Cam Behaviour problems in Unity 5 32 bit

April 5, 2015 - 2:00pm #4

Hi. I'm still with this problemI'm using the latest version of Vuforia(4-0-103) with Unity5(5.0.0f4)x64. Does anyone know of another solution ?

Web Cam Behaviour problems in Unity 5 32 bit

March 19, 2015 - 7:12pm #3

For anyone that is curious, I managed to get this to work by updating to the very latest Vuforia 4 files (4-0-103), which seem to fix the problem.

Web Cam Behaviour problems in Unity 5 32 bit

March 19, 2015 - 6:28pm #2

As an update, I've now set up a proper profile for the webcam I am using (Microsoft Lifecam VX-2000), so I no longer get the missing profile error, but I still get the generic 'An error occurred' problem, and the black camera input.

Also, the webcam I'm using works perfectly fine in Unity 5 as a Webcam Texture.

Matt

Log in or register to post comments