Topic locked

What makes the BackgroundCamera(Clone) render to only the lower-left area on the screen when built to iOS?

February 23, 2015 - 11:34am #1

It fills the entire window in the Editor.

What makes the BackgroundCamera(Clone) render to only the lower-

February 24, 2015 - 10:34am #13

OK, that explains it. 

If interested in trying the 4.0 beta, you can download it from:

https://developer-beta.vuforia.com/

 

UPDATE:

The final commercial 4.0 release is expected to launch this week.

 

What makes the BackgroundCamera(Clone) render to only the lower-

February 24, 2015 - 9:56am #12

We are also using 3.0.9, since we are using Cloud Recognition, which isn't available in 4.0 beta. Good to know that the problem doesn't appear to exist in the 4.0 beta, though. Looking forward to the release of 4.0 so we can try it out.

What makes the BackgroundCamera(Clone) render to only the lower-

February 24, 2015 - 9:36am #11

Hi Alessandro,

I was using Vuforia 3.0.9 ....

Thanks anyway for your feedback 

What makes the BackgroundCamera(Clone) render to only the lower-

February 24, 2015 - 9:26am #10

Gentlemen,

I've just tried building and running a simple Vuforia 4.0 beta app (ARCamera + 1 Image Target) with Unity 4.6.3 on 2 different devices (an iPhone5S with 64bit CPU and an iPad mini with 32bit CPU),   both running on iOS 8.1.3, and everything seems to work correctly (camera renders OK and in fullscreen).

 

I wonder if your issue is simply connected to the Unity version upgrade process for an existing project; have you tried the following ?

- close Unity

- remove the Library folder under your Project root

- reopen your project in Unity 4.6.3

?

 

 

What makes the BackgroundCamera(Clone) render to only the lower-

February 24, 2015 - 5:31am #9

turi wrote:

Hi Alessandro,

I tried all of your suggested settings on Unity 4.6.3 and the problem was still there. By the way the workaround suggested by Patchedreality worked fine. Just downgraded to Unity 4.6.2f1.

 

ditto, I tried the suggestion for 4.6.3 but still had problem, so back to 4.6.2 and it works OK now...

What makes the BackgroundCamera(Clone) render to only the lower-

February 24, 2015 - 2:35am #8

Only happens on the device. In the editor everything is fine. It happened on iPad Air 2 and iPhone 5. Haven't tested on other devices so far.

What makes the BackgroundCamera(Clone) render to only the lower-

February 24, 2015 - 2:27am #7

does it happen only when running on the iOS device ? is it specific to a certain device ?

What makes the BackgroundCamera(Clone) render to only the lower-

February 24, 2015 - 1:02am #6

Hi Alessandro,

I tried all of your suggested settings on Unity 4.6.3 and the problem was still there. By the way the workaround suggested by Patchedreality worked fine. Just downgraded to Unity 4.6.2f1.

What makes the BackgroundCamera(Clone) render to only the lower-

February 24, 2015 - 12:58am #5

Thanks!!!  You were right. Just downgraded to Unity 4.6.2 and it worked perfectly !

What makes the BackgroundCamera(Clone) render to only the lower-

February 23, 2015 - 11:27pm #4

Unity 4.6.2 p2 introduces "Metal" support on iOS, next to OpenGL ES 2.0 and 3.0;   the same applies to Unity 4.6.3

so, it sounds like the issue you're seeing on iOS might be related to the Player Settings;  just make sure to set the rendering settings to OpenGL ES 2.0

Additional note:

if you use Vuforia 3.0, make sure the "Scripting Backend"  is set to MONO and the architecture is set to armv7;

on the other hand, if you use Vuforia 4.0+, on iOS, you should set the Scripting Backend to IL2CPP and select the Universal architecture (armv7 and arm64)

 

What makes the BackgroundCamera(Clone) render to only the lower-

February 23, 2015 - 3:17pm #3

We are seeing the same thing. This started happening with 4.6.2p2. Everything was working fine as of 4.6.2f1. So, if you need a workaround, try version 4.6.2f1 of Unity, and stay away from anything more recent.

I don't know yet if there is a way to fix this on the latest Unity. Anyone?

What makes the BackgroundCamera(Clone) render to only the lower-

February 23, 2015 - 3:03pm #2

..same problem here !!

Topic locked