Log in or register to post comments

why can not get the target in the Inspector?

February 4, 2013 - 6:56pm #1

Hi all,

          Sorry for my stupid question, I'm a beginer. I had followed the step https://developer.vuforia.com/resources/dev-guide/step-2-compiling-simple-project

to do a sample, but when I added the sample " ImageTarget " in my scene, the inspector show there is no target to be defined, then I clicked the message it will link to my  "Target Manager" area in Vufoia.com.  Anyone could tell me the reason ?

thanks all~~

why can not get the target in the Inspector?

February 8, 2013 - 1:29am #8

Yes, you need the pro license; you're welcome.

why can not get the target in the Inspector?

February 7, 2013 - 10:07pm #7

thanks a lot ! I'm using the free version, It seems I must install the pro version to test the camera, tks

why can not get the target in the Inspector?

February 6, 2013 - 11:01pm #6

Hi, the reason why the camera is not shown could be your Unity license; are you using Unity Pro ?

If you have an Android Basic license, the feature is not available, it requires Pro license.

Check here:

https://developer.vuforia.com/resources/dev-guide/unity-play-feature

 

why can not get the target in the Inspector?

February 6, 2013 - 7:45pm #5

Thank you very much!! I will try it . And I want to know, how to set the camera in the Inspetor ? My notebook have a camera but the Inspetor show none camera to find~~~

why can not get the target in the Inspector?

February 5, 2013 - 11:04pm #4

OK, what you need to do is:

  • go to the online Target Manager

https://developer.vuforia.com/targetmanager

  • create a Device Database (e.g. called "MyImageTargets")
  • create a target (or how many targets as you want
  • download the Database, specifying the option "Unity package"; this will create a package "MyImageTargets.unitypackage" and will download it to your download directory
  • in Unity, import that package 'MyImageTarget.unitypackage) via Menu->Assets->Import Paclage->Custom Package...
  • in the Prefabs view of your project, the MyImageTargets.XML and MyImageTargets.DAT will magically appear under the StreamingAssets/QCAR folder
  • Now, if you go to the Inspector, for ARCamera-> QCARBehaviour script -> you will see a box "Load Data Set MyImageTargets", which you can tick (enable); also enable the "Activate" box right below.
  • Again in Inspector, for your Image Target game object, look at ImageTarget Behaviour script => you will see the Data Set field and the Image Target field that you can set to your Database and target (via combo box)

Thats'it.

Let me know if anything is not clear.

 

why can not get the target in the Inspector?

February 5, 2013 - 5:47pm #3

Hi,

      I hv imported  vuforia-unity-android-ios-xx-yy-zz.unitypackage  ,  and I did not download the .DAT and .XML from the online TargetManager. How could I import the .DAT and .XML to the project ? 

Thanks a lot

 

why can not get the target in the Inspector?

February 5, 2013 - 12:37am #2

Hi, when you say:

but when I added the sample " ImageTarget " in my scene

what do you mean exactly ?

Have you imported a .unity package after downloading it from the online TargetManager ? or have you copied the .DAT and .XML files from another project ?

 

Log in or register to post comments