Log in or register to post comments

XML Exception invalid data

March 31, 2017 - 5:11pm #1

Getting this error in the editor out of nowhere it seems. Even BEFORE I try and publish.

 

Everything was fine.

 

Same error with Unity 5.5.2f1 on BOTH Mac OSX and Windows.

latest Vuforia

Is there something wrong with my Vuforia install?

If so, how does this happen?

How do I fix?

 

 

XmlException: invalid data.

System.Xml.XmlStreamReader.Read (System.Char[] dest_buffer, Int32 index, Int32 count)

Mono.Xml2.XmlTextReader.ReadTextReader (Int32 remained)

Mono.Xml2.XmlTextReader.PeekChar ()

Mono.Xml2.XmlTextReader.ReadContent ()

Mono.Xml2.XmlTextReader.Read ()

System.Xml.XmlTextReader.Read ()

Vuforia.EditorClasses.ConfigParser.fileToStruct (System.String configXMLPath, System.String authoringInfoXMLPath, Vuforia.EditorClasses.ConfigData configData)

Vuforia.EditorClasses.ConfigDataManager.ReadConfigData (System.String dataSetFilePath)

Vuforia.EditorClasses.ConfigDataManager.DoRead ()

Vuforia.EditorClasses.SceneManager.InitScene ()

Vuforia.EditorClasses.ImageTargetEditor.EditorConfigureTarget (Vuforia.ImageTargetAbstractBehaviour itb, Vuforia.EditorClasses.SerializedImageTarget serializedObject)

Vuforia.EditorClasses.ImageTargetEditor.OnEnable ()

XML Exception invalid data

June 3, 2017 - 4:59pm #3

so the solution is the following. If you XmlException: invalid data. Error do the following.

Find .xml data file in StreamingAssets/qcar folder.

Copy that file in other place.

Open .xml file in TextWrangler and save it with the following settings. Line breaks - Windows(CRLF). Encoding - Western(Windows Latin1). If you have not seen that settings in TextWrangler - just add it in Preferences.

Then close Unity3d.

Paste new saved .xml file in proper folder.

Open Unity 3d again.

If you have the same error - you have to do that operation with all .xml files in Qcar folder.

 

XML Exception invalid data

April 4, 2017 - 6:16pm #2

Hello,

Have you recently upgraded your project to a new version of Vuforia?

Thanks.

Log in or register to post comments