Log in or register to post comments

3D Objects sliding on printed marker

January 18, 2018 - 6:25am #1

Hi there,

i got a problem where the 3D Objects are sliding away from the marker when I move my device (iPad Pro 12,9"). I created a new Project and positioned (snap) some primitives of Unity at the edges of a standard Vuforia marker (Image target, stones). I built it onto the iPad and look straight at the marker everything seems to be ok, but when i move a few steps away from the marker, to see all objects, the objects are not at the correct position anymore(around 2-4cm difference). Eventhough when i move around the marker, the objects are always displaced in a weird direction, which is not always the same. By tilting the iPad (left and right), the objects are moving to the opposite side than the tilt.

I also tried it on several iPhones, iPads and Android devices. My expectation is that the objects are still placed at the edges of the marker, but they are kind of sliding "away".

I use Unity3D 2017.3 and the integrated Version of Vuforia 7. I also tried some other settings in the Vuforia configuration but the problem is still there. In my Project i need to use the Extended Tracking, but the wrong positioning without, is there too.

What I've tried:

  • using another marker
  • creating a new project
  • use another device
  • World Center mode changed
  • Extended tracking on/off
  • Camera optimization (speed/quality)

My guess is, it could have something to do with the projection matrix or the intrinsic parameters of the camera. Maybe someone can help me.

Thanks in advance!

3D Objects sliding on printed marker

January 26, 2018 - 6:34am #13

No response from anyone at Vuforia in this thread and want to make sure someone sees it.  Consider posting a summary of your findings or a link to this post in the Bugs section of the forum so this post isn't missed.  

3D Objects sliding on printed marker

January 26, 2018 - 5:54am #12

Hi martejpad,

I'm afraid you're right. After some test the positioning is still not quite correct. Doesn't seem to have been the solution after all. In autorotation: The faster the iPad is rotated, the greater the deviation in positioning. There's an error related to the rotation of the device, what we can't make any sense of. Maybe it will be fixed in further versions.

best regards

3D Objects sliding on printed marker

January 26, 2018 - 3:17am #11

Hi Mrvn,

What an unexpected trick!

I've just tested it for the Vuforia Samples app I was using and it does indeed improve things quite a lot. The object sliding when moving the camera from left to right is not there anymore, however it is still a bit noticeable when moving the camera up and down.

Also, the initial position of the object is still quite off for me :(

Thanks so much for sharing this with us, let's hope this gives the Vuforia team some good hints to solve the issue.

Kind regards and have a good day

3D Objects sliding on printed marker

January 25, 2018 - 4:10am #10

Hi martejpad,

we've gained a new insight.

Is your app on something other than "Auto Rotation" in the Player Settings?

If yes, switch to auto rotation mode, the tracking will work (at least in our case). Problem is that we need the app in portrait mode. I will try to write a workaround for it.

But still there is a bug in Vuforia I guess, cause you can't fix the screen orientation.

 

Best regards

3D Objects sliding on printed marker

January 22, 2018 - 7:37am #9

Hi Mrvn,

Sadly no, no progress at all.

The Vuforia guys have not replied to my other post either.

Honestly I'm not sure what to do. For me the biggest problem is that the position of the 3D objects are totally off. Without that Vuforia is essentially unusable for me.

Let's hope they help us!

Thanks :)

 

 

3D Objects sliding on printed marker

January 22, 2018 - 3:01am #8

Hi martejpad,

actually I don't see those black strips you mentioned.

Have you made any progress or did you find something new?

Thanks!

3D Objects sliding on printed marker

January 19, 2018 - 4:06am #7

Thanks Mrvn!

Yesterday I noticed that when these black strips appear the starting position of the cube (before moving the camera around and the sliding happening) is correct. Here are a couple of screenshots to illustrate what I mean:

With black strips + correct position: https://drive.google.com/open?id=1LnQZlTvwHHx1ZKn4thbzXy_u8JJj3-Lf

Without black strips + incorrect position: https://drive.google.com/open?id=1EY8cQkW5v88TAFQ2Fw-tu8nfM-KI0ByJ

Thanks again!

 

 

3D Objects sliding on printed marker

January 19, 2018 - 3:50am #6

Hi martejpad,

thanks for your reply.

It seems that you've got the same problem. I can't mention some "black stripes" on restarting the app. Maybe you can post a screenshot? Or is it just for one frame? 

And you are right, this problem was not there when I developed for an iPad Pro 10.5" on an older iOS Version. I can't test it now on an older iOS, cause I don't have an iPad with such an iOS Version. But thanks for pointing this out!

Maybe we can figure something out here. Thanks!

3D Objects sliding on printed marker

January 19, 2018 - 3:27am #5

Here's the video: https://drive.google.com/open?id=11R7qnPNob6zs0Vv5apF_d2PoZhqq_DNh

Please notice:

1) how the cube aligned on top of the N letter of "OXYGEN" is sliding around. Second 22 of the video is a good example.

2) how the position of the cube is almost never correct. It should be in perfect alignment with the N as you can see inside the Unity project: https://drive.google.com/open?id=1OBFo21TR_fo-BP9qfAfxD4ftMrJgjjQd

I can confirm these issues don't happen with an iPad Mini 2 with iOS10. There's a tiny bit of sliding but it's hardly noticeable and the starting position of the cube before starting to move the camera around is totally correct. I'm currently upgrading another old iPad Mini 2 to iOS 11.2 to see if this is device-specific or not. Will report back.

Thanks!!

3D Objects sliding on printed marker

January 19, 2018 - 3:02am #4

Hello both,

I posted a new thread last night about a similar problem but it seems it hasn't been approved yet as it doesn't appear on the forum.

I can confirm I have exactly the same problem on an iPad Pro 10.5 inches + iOS 11.2 + Unity2017.3 and Vuforia 7.0.36. I will record a video and post it in a few minutes.

I described the problem differently on my post yesterday because I hadn't realised the position of the augmentations varied when moving the camera - I had simply noticed that they were positioned incorrectly. 

Mrvn, does it happen to you that when you pause the app and restart it again two black strips appear on the sides of the background image?

I really hope we can get to the bottom of the problem! 

Many thanks :)

3D Objects sliding on printed marker

January 19, 2018 - 2:36am #3

Hi dpizzle,

thanks for your reply!

I made some videos with the actual "Astronaut" marker and some primitives. With and without extended tracking. As you can see the problem is still there. I tried a autofocus script, cause the iPad is not focusing very well in Vuforia, but no difference.

Here the Videos:

Extended Tracking On

https://www.dropbox.com/s/445lz55gzgb86m2/Extended%20On.MP4?dl=0

Extended Tracking Off

https://www.dropbox.com/s/bpig7wptsoabz2y/Extended%20Tracking%20Off.MP4?dl=0

Scene Screenshot in Unity

https://www.dropbox.com/s/kc8ohwctsw80nak/Scene.png?dl=0 (primitives are snapped to the edges of the Image Target)

Vuforia Example Project

https://www.dropbox.com/s/3w7hk94kx9gzg0o/Sample%20Project.MP4?dl=0 (I placed some primitives here too, but u can see that the astronaut is also sliding around the center point)

What you see in the Video is that when I move closer to the marker, the positioning is more or less correct. But if there is some distance between the camera (iPad) and the marker, the primitives are displaced. Also the position of the Objects is different by moving the iPad around?!

I hope this shows my problem in detail, so you can see what I mean. And maybe you or someone else got a solution for me. 

Thanks in advance!

3D Objects sliding on printed marker

January 18, 2018 - 9:26am #2

This doesn't sound normal.  With extending tracking on, maybe, but with it off it should be pretty solid.  Have you tried the Vuforia sample project?  Also, a link to a video might help figure out what is going on.

 

Log in or register to post comments