Log in or register to post comments

Android "Bad Frame Quality" error when closing & reopening app

March 18, 2019 - 3:09am #1

On an Android build using Unity 2018.2.18f1 everything works fine, but when I close the app and then reopen it after a while the "UPDATE ERROR BAD FRAME QUALITY Low-frame quality has been continuously observed" error is there. Tapping close dismisses it and everything works fine again, but this happens every time the app gets "minimized" for a bit and then reopened.

Android "Bad Frame Quality" error when closing & reopening app

March 25, 2019 - 3:04pm #6

Hi Alex,



We're experiencing this same issue. If you managed to disabled the warning message, could you please share the details of how you did it?

Android "Bad Frame Quality" error when closing & reopening app

March 21, 2019 - 2:39am #5

Not sure what it could be, but as you said it's just a warning that I can disable and doesn't impact the user's experience at all so I'll just disable it. Thanks for the help!

Android "Bad Frame Quality" error when closing & reopening app

March 19, 2019 - 5:31am #4

Hello,

When the SDK Cloud Reco service is enabled, each camera frame is analyzed for two properties:

  • A "scene change", which determines if what is in the the camera's field of view has changed, and
  • Frame quality, which determines if an incoming camera frame is in-focus, exhibits no blurring and has sufficient lighting for recognition

If both of these conditions are met, then the SDK service will trigger a "query" to the Cloud Reco server.

Strange that you don't see it in the samples, but do see it in your updated project. Ultimately, this is just a warning message that is part of the sample's UX so it is not really necessary.

Thanks,

Vuforia Engine Support

Android "Bad Frame Quality" error when closing & reopening app

March 18, 2019 - 10:07am #3
  • Cloud Recognition
  • No
  • OnePlus 3, Android 8

 

Vuforia version: 8.0.10

 

I based my current project off of the cloud recognition sample scene and haven't really made heavy modifications.

Android "Bad Frame Quality" error when closing & reopening app

March 18, 2019 - 6:30am #2

Hello,

A few questions:

  • Which Vuforia feature are you running when this was observed?
  • Does this occur when running the Vuforia Core samples (unmodified)?
  • And on which device model?

Thanks,

Vuforia Engine Support

Log in or register to post comments