Log in or register to post comments

App works and Build and Run, but does not when installing manually or downloading from the play store

December 21, 2018 - 12:16pm #1

Hello there!

 

Vuforia fails to initialize when I download it from the google play store, but works fine when I hit Build and Run on Unity.

This is what it prints on logcat:

 

NullReferenceException: Object reference not set to an instance of an object

12-21 18:09:38.290 27000 27018 E Unity   :   at UnityEngine.JsonUtility.FromJson[EulaVersionStrings] (System.String json) [0x00000] in <filename unknown>:0

12-21 18:09:38.290 27000 27018 E Unity   :   at Vuforia.EulaJsonUtility.JsonToVersionStrings (System.String json) [0x00000] in <filename unknown>:0

12-21 18:09:38.290 27000 27018 E Unity   :   at Vuforia.PlayModeEditorUtility+NullPlayModeEditorUtility.IsVuforiaActiveAndEULAAccepted () [0x00000] in <filename unknown>:0

12-21 18:09:38.290 27000 27018 E Unity   :   at Vuforia.VuforiaRuntime.IsVuforiaActiveAndEULAAccepted () [0x00000] in <filename unknown>:0

12-21 18:09:38.290 27000 27018 E Unity   :   at Vuforia.PlatformRuntimeInitialization.InitPlatform () [0x00000] in <filename unknown>:0

12-21 18:09:38.290 27000 27018 E Unity   :

12-21 18:09:38.290 27000 27018 E Unity   : (Filename:  Line: -1)

12-21 18:09:38.290 27000 27018 E Unity   :

12-21 18:09:38.298 27000 27018 E Unity   : NullReferenceException: Object reference not set to an instance of an object

12-21 18:09:38.298 27000 27018 E Unity   :   at UnityEngine.JsonUtility.FromJson[EulaVersionStrings] (System.String json) [0x00000] in <filename unknown>:0

12-21 18:09:38.298 27000 27018 E Unity   :   at Vuforia.EulaJsonUtility.JsonToVersionStrings (System.String json) [0x00000] in <filename unknown>:0

12-21 18:09:38.298 27000 27018 E Unity   :   at Vuforia.PlayModeEditorUtility+NullPlayModeEditorUtility.IsVuforiaActiveAndEULAAccepted () [0x00000] in <filename unknown>:0

12-21 18:09:38.298 27000 27018 E Unity   :   at Vuforia.VuforiaRuntime.IsVuforiaActiveAndEULAAccepted () [0x00000] in <filename unknown>:0

12-21 18:09:38.298 27000 27018 E Unity   :   at Vuforia.VuforiaRuntime.VuforiaInitialization () [0x00000] in <filename unknown>:0

App works and Build and Run, but does not when installing manually or downloading from the play store

January 2, 2019 - 12:33pm #2

Hello,

Did you upload as a split binary? If so and you're using a device database, you'll need to take additional measures:

https://developer.vuforia.com/forum/unity/load-dataset-android-split-binary-obb

Thanks,

Vuforia Engine Support

Log in or register to post comments