Log in or register to post comments

Apple Mach-O Linker (id) Error

September 1, 2017 - 12:33am #1

This really starts to annoy me.

I googled and tried different "solutions" for this and either I find outdated stuff or it led me to more errors.

I'm using Unity 5.6.1f1

Xcode 8.3.3

Vuforia 6.2

The Error I get is:

Apple Mach-O Linker (id) Error

Undefined symbols for architecture arm64:

  "_OBJC_CLASS_$_ALAssetsLibrary", referenced from:

      objc-class-ref in ImgTOAlbum.o

ld: symbol(s) not found for architecture arm64

clang: error: linker command failed with exit code 1 (use -v to see invocation)

Android works perfectly fine. I know iOS could be a bit more picky about certain things. I'm using the Region Capture Plugin ... but I found that other users managed to bring it on Apple as well.

So what can I do about it?

I tried to disable Bitcode, Dead Code Stripping is enabled... I'm slightly running out of possible issues.

Any help is really appreciated. Thanks in advance

Apple Mach-O Linker (id) Error

September 1, 2017 - 1:26am #2

Ok one for the dumb guys like me, it basically RTFM (but as a usually-non-xcode-user you've got to know where to find the correct stuff).

You need to Add "AssetsLibrary.framework" in General > Linked Frameworks and Libraries just click on the "+" and type in "assets" and there you go.

Gosh. Now I can breath freely...

Log in or register to post comments