Log in or register to post comments

AR Object gets stuck on Android screen

June 17, 2019 - 2:59pm #1

Hello.

In the video attached, you can see the problem. In case the gif in the attachment doesn't work, here is a Reddit link where you can find the video as well. 

(      Link:        https://www.reddit.com/r/Unity3D/comments/c1tes3/question_about_vuforia_ar_object_gets_stuck_on/      )

If my Android phone’s camera detects the image target (a front packaging), then the ingredients will be augmented. However, if I move the camera away from the image target (the image target itself remains in the same position), the ingredients seem to stick to the screen, even though the image target is not in sight. My goal is make the augmented object(s) disappear if the image target is not detected.

This specific problem can be solved if I go to ‘VuforiaConfiguration’ and under ‘Device Tracker’, I enable ‘Track Device Pose’, then select ‘ROTATIONAL’ as the tracking mode. However, I specifically don’t want to use ‘ROTATIONAL’.

I want to either (1) disable ‘Track Device Pose’ altogether, or (2) enable ‘Track Device Pose’ and select ‘POSITIONAL’ as the tracking mode.

Regarding the settings of the ARCamera and ImageTarget, I just used the default settings. I did not make any modifications (For example, I did not alter the ‘DefaultTrackableEventHandler’ script).

I tried to resolve my problem using:

(1) Unity 2018.2.21f1 & Vuforia version 8.0.10.

(2) Unity 2018.4.2f1    & Vuforia version 8.1.11.

(3) Unity 2019.1.7f1    & Vuforia version 8.1.11. 

Is there another way to make the augmented objects not stick to the screen (besides selecting ‘ROTATIONAL’ as tracking mode)? I gladly accept any advice/tips.

Thank you.

AttachmentSize
Image icon DemoVuforiaErrorGif.gif39.35 MB
Log in or register to post comments