Log in or register to post comments

ARCamera errors (tried to fix blurry camera, went terrible)

May 30, 2018 - 3:23am #1

Hi all,

First, sorry for my bad English. For my study I thought it would be fun to make something in Augmented Reality (never done it before, but it worked very well). Tried Build&Run on my Android phone and no problem; the AR worked like it should be. So, happy as I was, continued on this project.

Till today... For a final test, again I did Build&Run my project to my phone. No problems except that the camera in the app was so blurry it could not recognizes the image targets, so no AR appeared.

I read something about the autofocus and scripts - I don't know anything of scripts and stuff, but I just copied and add the scripts like advised to the ARcamera, like, what could go wrong?

Well, clearly everything could go wrong. Errors appeared (Unity says the scrips can not be loaded and so on), and I can not Build&Run the app, not even check it with my webcam in Unity. I tried to open a previous version of my project, but it gave the same error. Is there a way to solve this issue? Like, resetting the scripts of something? I hope someone can help as my deadline is tomorrow! :(

Please please please help this damsel in distress and I'll be forever in your debt!

ARCamera errors (tried to fix blurry camera, went terrible)

May 30, 2018 - 10:49am #2

Hello MCVD,

Which version of Unity and Vuforia are you using? What scripts did you add? Our sample projects, available on the Unity Asset Store, have examples of using autofocus, I'd recommend reviewing those to understand how to add it to your project.

Thanks,

Vuforia Support

Log in or register to post comments