Log in or register to post comments

ARCore in Unity breaks Vuforia

September 19, 2018 - 2:09am #1

I'm trying to test ARCore in conjunction with Vuforia in Unity by following official guide: https://library.vuforia.com/content/vuforia-library/en/articles/Solution/arcore-with-vuforia.html I downloaded ARCore library (core-1.4.0) and placed itnto plugins/android folder. On the Galaxy S9 I'm getting weird camera issue with green stripes and stereoscipic view. Without ARCore library Vuforia works fine! Did I miss some settings for project? I tried disabling Multithreaded rendering, uplifting android API requirements but nothing worked yet.


Switching from the app back and forth fixes this issue! So it looks like a bug

ARCore in Unity breaks Vuforia

September 25, 2018 - 10:52am #3

Thank you for response! I found out that extended tracking enabling script was causing such issues:
void OnVuforiaInitialized()
var deviceTracker = TrackerManager.Instance.InitTracker();
VuforiaConfiguration.Instance.DeviceTracker.FusionMode = FusionProviderType.OPTIMIZE_IMAGE_TARGETS_AND_VUMARKS;

Can't say what line exactly is causing it but probably starting device tracker without ensuring there is other tracker still active. Maybe you should add some additional fool proof check for this :)

ARCore in Unity breaks Vuforia

September 21, 2018 - 4:25pm #2

Hello dnnkeeper,

We haven't encountered this issue internally. Would you be able to try using ARCore 1.3 instead and see if you get the same results? We are rolling out ARcore 1.4 support in the next major release of Vuforia (coming within the next week) and this may resolve the issue for you.

Are you only seeing this issue on this device, or have you encountered it with other devices as well?


Vuforia Engine Support

Log in or register to post comments