Log in or register to post comments

Automated builds broken by needing to accept Vuforia 7.5 license every time launching unity

October 9, 2018 - 7:32am #1

We use OSX Unity automated build machines but since upgrading to Vuforia 7.5 the builds don't work properly as the automated build system is unable to click the 'accept' popup that seems to happen every time Unity is opened with a Vuforia enabled project.



Is there a way to just accept the license just once so that it isnt neccesary to have to accept each time we make a new build?

Running Unity as a super user and then accepting doesn't seem to work.



Thanks

Automated builds broken by needing to accept Vuforia 7.5 license every time launching unity

October 30, 2018 - 6:08am #6

Is this fix by any chance the reason that Cloud Build stopped working?

If so, could you elaborate on the change/fix? Then we can have a look at a workaround for cloud build using post/pr-build scripts.

Automated builds broken by needing to accept Vuforia 7.5 license every time launching unity

October 16, 2018 - 3:05pm #5

@preloaded thanks for responding.

-Vuforia Engine Support

Automated builds broken by needing to accept Vuforia 7.5 license every time launching unity

October 16, 2018 - 8:50am #4

Sorry for the delay in reply, only just checked the forums.

Have just gone to launch Unity to get the Editor log and it now isn't asking for me to accept the license!!!! :o

No idea what happened, but i'm happy now.

For interest, i was using Unity 2018.2.6f1 and running it on osx 10.13.6

Automated builds broken by needing to accept Vuforia 7.5 license every time launching unity

October 10, 2018 - 5:53am #3

Hi, the license should only need to be accepted once per Vuforia version and machine.

If you need to accept this over and over again this means it's not persisted correctly, which we haven't been able to reproduce in our testing.

Can you please do the following to help us debug this:

  • Open the Unity project manually on the build machine
  • Is the license popup being shown now?
  • Accept the license
  • Close Unity
  • Please send us:
    • The exact Unity version you are using
    • The full Editor log from ~/Library/Logs/Unity/Editor.log
    • From your Unity project, the manifest.json from the Packages folder

Many thanks!

Vuforia Engine Support

Automated builds broken by needing to accept Vuforia 7.5 license every time launching unity

October 9, 2018 - 1:40pm #2

Hello,

I've escalated this to our team and will get back to you.

Thanks,

Vuforia Engine Support

Log in or register to post comments