Log in or register to post comments

Black flashes on parts of the screen (iOS)

June 28, 2018 - 5:26am #1

Hi there.

I have the following problem:

This only happens in iOS (iPad Pro, iPad Pro v2, iphone 7, etc...)

Unity 2018.1.4f1

Vuforia 7.1.35

Graphics API: (only) OpenGLES2

I deleted all UI elements in the scene, on Android, Windows and MacOS this doesn't happen. It also doesn't happen on other AR scenes in the same App. It only happens in two scenes. This one and way less "black flashes" in the other one. I can't find a commonality between the two scenes that the others don't share. Has anybody had similar problems?

Thank you for your time.

Black flashes on parts of the screen (iOS)

January 13, 2019 - 11:27pm #5

The solution that worked for me is to change the near plan distance of the camera to 0.2.

Hope this solves your issue

Black flashes on parts of the screen (iOS)

October 2, 2018 - 3:36am #4

I faced this problem too when I tried to play videos and it was really frustrated.

I tried the solutions @AtticusDigital provided, but it seemed that it didn't work out.

Anyone has other solution for this?

Black flashes on parts of the screen (iOS)

August 15, 2018 - 10:04am #3

We've encountered similar issues, random black shapes being cut out of the camera texture, with two possible triggers.

The first seems to be related to pose tracking (rotation/position tracking).  On some of our test devices (Pixel, Pixel XL, Pixel 2 and Pixel 2 XL to be specific), having pose tracking enabled triggered the black flickering.  If you uncheck 'Track Device Pose' in the Vuforia configuration, that seems to resolve this particular issue for us ... but of course, if you need that functionality, this isn't much help.

The second appears to be related to enabling and disabling Vuforia too rapidly during initialisation.  In one scene, we had a Vuforia camera which was enabled in the scene, but disabled during 'start', and then re-enabled later, and this triggered black flashing.  We resolved that issue by starting the scene with the camera disabled, and presumably allowing it to initialise properly when it finally is needed.

I hope one of these two is of help, but I've heard of other developers encountering the mysterious black flickering of doom, so I believe there are other triggers out there.

Black flashes on parts of the screen (iOS)

August 8, 2018 - 3:20am #2

I´ve got exactly the same problem on 2 different android devices:



Galaxy S 5

Android 6.0.1

 

Huawei MediaPad M3 Lite 10

Android 7.0



 

using Unity 2018.1.6f1.

 

On a Galaxy S8 i don´t have these problem.

 

Log in or register to post comments