Topic has a solution and is locked
Topic locked

Black screen running Core Samples App - UWP

SDK 10.0
August 18, 2021 - 5:46pm #1
Topic solved

Hi,

I'm trying to build the Vuforia Core Samples Unity App for UWP. Inside the Unity Editor the application works as expected. However, in the resulting UWP application the AR camera displays a black background. No targets are detected even though the camera light on my computer turns on.

I'm attaching a screenshot of the application runing in the editor and the Image Targets scene in the UWP app that was built in Visual Studio.

This is what I have tried so far:

  • Tested different Windows SDKs:

       Windows 10 SDK, version 2004 (10.0.19041.0)

       Windows 10 SDK, version 1903 (10.0.18362.1)

  • Tested also Vuforia 9.8 and I had the same behaviour.
  • Was able to reproduce on a different computer

Versions:

  • Unity 2020.3.8f1
  • Visual Studio Community 2019 Version 16.10.4
  • Vuforia Engine AR 10.0.12
  • Vuforia Core Samples 10.0.12

I'd appreciate anyone's input.

Thank you.

SDK Version: 

Black screen running Core Samples App - UWP

September 7, 2021 - 10:29am #3

Hey both,

 

Vuforia Engine is not commercially supported to be built for Windows 10 devices such as desktops and laptops apart from a selected few.

We only support a handful of devices for UWP: https://library.vuforia.com/platform-support/vuforia-engine-recommended-devices.html

 

Kind regards,

Patrick Scheper

Technical Community Manager

Black screen running Core Samples App - UWP

September 7, 2021 - 5:35am #2

Up the thread , I have an issue with my unity editor that  is a black screen too 

 

 

 

 

snaptube vidmate

Topic locked