Log in or register to post comments

Camera and Target issues on Android

February 27, 2018 - 2:11am #1

Hello,

I am currently facing two issues using Vuforia and Unity for an AR app. I decided to have them both in a single post since they have some relation to each other.

 

Issue #1

Camera is so zoomed in it's impossible to discern anything - but the detection still works, when I somehow manage to get the target in frame. 

This problem seems to only happen when switching scenes (the very first scene loaded works just fine though). If I build the same project, with the same settings, but only the AR scene, everything works. But this is not really helpful since I am forced to cram everything in a single scene.

I've tried messing around with every setting I could think of, from Vuforia, Camera and Target. I've tried adding AR cameras to non-AR scenes and disabling VuforiaBehaviour on them, like I read somewhere. I've tried a script that disables everything Vuforia related in my cameras on the Start() method. I've even tried making a kind of singleton camera that destroys all but the first instance right during Awake(). Nothing works... at all.

 

Issue #2

So, despite complaining, I still tried putting the whole app in a single scene. But then I found out the targets no longer worked!

If I build an AR scene featuring a single target, both images I am using work perfectly fine - they are detected almost instantly.

But when both are in the same scene, one of them is not detected. And if I switch their order in the Hierarchy, both stop working.

This is baffling.

Specially since their game objects are inactive by default and I have to explicitly choose one from a menu, which then activates the correct target while deactivating the other, so there should be no overlap or whatever.

And changing the number os simultaneous image targets in the settings did not fix this.

 

 

So, you see mi dilemma now? Having both targets in the same scene seems to be breaking one of them, but loading scenes is breaking Vuforia itself...

Whats more, some older apps I had which relied on Vuforia did not experience such problems... but downgrading Unity and Vuforia is out of the question (it would break too many things).

 

I cannot afford to give up, but I am also getting a little desperate so... help?

Camera and Target issues on Android

May 27, 2018 - 10:30pm #5

Android Issue explanation: a blank screen appears for a few moments (it's usually less than half a second), after the target was detected

When?: right after a target is detected, and the video is right about to start (PLAYING state)

Camera and Target issues on Android

March 6, 2018 - 10:00am #4

Are you seeing this same behaviour in Unity Playmode? Do you have other devices to test against? Do you see the same thing with the Core Samples?

Thanks,

Vuforia Support

Camera and Target issues on Android

February 28, 2018 - 1:59pm #3

Hey Strasza,

 

I'm using Unity 2017.3.1p2 - upgraded from 2017.3.0f0

As for Vuforia, it's 7.0.47:dd7269778b6af1499dec0d5f1dfb0c2c (copied directly from the file that comes with it)

 

Starting a brand new project yields the same result, so this probably has to do with this latest versions (this seems to happen in every version up from 2017.3.0 - haven't tested older ones)

Here are the steps I followed:

1) Create a new project

2) Enable Vuforia AR in the XR Settings within the project build settings

3) Create a scene with an ARCamera and an ImageTarget

4) Create a regular scene that will open before the AR one

5) Make a script that loads the AR scene after one second

6) Make a development build and run the apk in your device

 

ps: the device where this was tested is a Moto G5 Plus running Android 7 (Nougat) - I haven't had the opportunity to try another device yet

Camera and Target issues on Android

February 27, 2018 - 4:22pm #2

Hello blacklab,

Which version of Unity and Vuforia are you using? It sounds like from your post you have migrated from a previous version as well, which versions did you migrate from? Are you able to reproduce this within the latest sample projects?

Thanks,

Vuforia Support

Log in or register to post comments