Log in or register to post comments

Could not find reference material DefaultTarget.mat

August 26, 2019 - 6:19am #1

I get always this error. I reimported package and installed defaultTarget.mat but neverthless giving this error. I tried assign the material and does not work

 

Could not find reference material at Packages/com.ptc.vuforia.engine/Vuforia/Materials/DefaultTarget.mat please reimport Unity package.

Could not find reference material DefaultTarget.mat

August 29, 2019 - 3:16am #5

Hi @protonmonkeys

The difference between 8.3.9 and 8.3.8 is due to an Unity issue, listing incorrectly the 8.3.8 version as 8.3.9.

Here you can find more information: https://developer.vuforia.com/forum/unity/known-issue-package-manager-upgrade-engine-839-incorrect

+ @Spacemarine & @protonmonkyes

In regards to the error you are facing, could you please confirm the following:

- Unity version?

- Did you upgrade to 8.3.8? if yes from which version?

Also could please disable/enable Vuforia from the XR settings (Under Edit -> Project Settings -> Player -> XR Settings) and let me know the outcome?

Thank you.

Vuforia Engine Support

 

 

Could not find reference material DefaultTarget.mat

August 29, 2019 - 1:52am #4

This happens even when starting from clean scene.

Especially, ImageTarget sample scene.

 

To reenact this, load ImageTarget scene and, click one of ImageTarget game object like ImageTarget_Astronaut,...

Then material disappears in the scene window, changes to pink material(for null), and console says

"Could not find reference material at Packages/com.ptc.vuforia.engine/Vuforia/Materials/DefaultTarget.mat please reimport Unity package."

 

And I imported vuforia plugin 8.3.9 in the package manager, and in the inspector of Image Target Behavior component, "Upgrade to Vuforia Engine 8.3.9 via Package Manager"

I use already 8.3.9...

 

Please save us :):)

Could not find reference material DefaultTarget.mat

August 27, 2019 - 10:14am #3

I am experiencing this same issue. 

 

Another odd thing is that after I did what was suggested - remove the package, restart, and then re-import vuforia package - the version number shown in the ARCamera properties window is 8.3.8 and has a button asking if I'd like to update to 8.3.9. In the package manager though, it shows that I have 8.3.9 installed.

 

I have tried several time and the same issue exists each time. 

Could not find reference material DefaultTarget.mat

August 27, 2019 - 3:05am #2

Hi,

Could you please confirm:

- On which version you are seeing this issue?

- Did you upgrade Unity or Vuforia beforehand? or is a fresh install?

After removing the Vuforia package, restart unity and try to import the package again.

Thank you.

Vuforia Engine Support

Log in or register to post comments