Log in or register to post comments

Custom target image doesnt work

February 8, 2018 - 6:19am #1

I have created a database in the vuforia webpage, set the width to scene size as it mentions, i use a a4 with borders so i set width to 0.158 , in image target i set it to predefined, the name of my database and the name of the image target and also loaded that database and activated it in the vuforia configuration but it doesnt work, with the astronaut image and the vuforia mars database works fine but not with a custom one. I use Unity 2017.3p2 

Custom target image doesnt work

February 22, 2018 - 6:29am #8

I made a perfect scan, everthing was green, then stopped the scanning, the item was saved, removed the object and continued scan again and stopped again. With the scan app it works 99% of the time with unity build 0%. the item has a bit reflective surfaces somtimes (its plastic) and light was direct but not intense.

Dont see any list of devices in the link you mention, i am using a samsung s8

I followed all the points

1. Lightning conditions were fine, but its a direct light

2. Positioned in the left hand corner

3. The axes appeared

4. Didnt move the object

5. Got all green in the scan, stopped recording, it showed me the screen to choose if discard or accept the record, i accepted it, and sent to the screen where i can choose if continue recording or test it. I removed the object and left the paper with grey background, selected continue recording, then stopped the record, i accept the record again then i added the od file which was in VuforiaObjectScanner/ObjectReco to the target manager, downloaded the unitypackage, imported it, scanned the item in the same environment and it didnt work

Custom target image doesnt work

February 21, 2018 - 10:58pm #7

Hello!

I'm using the core samples and then copied the "ImageTarget_Astronaut"  and renamed to "ImageTarget_sonic" changed to my picture from the drop down menu in the Image target behaviour. the Image target is sonic.

In the picture i have a app license i just took it out for the purpose of the screenshot.

And the picture I use got a 5 star rating, and my database is "Test".

 

PS Sorry to hijack your thread diegop, same area so thought i reuse, because i thought you were done.

 

 

AttachmentSize
Image icon vuforia config.png40.76 KB

Custom target image doesnt work

February 21, 2018 - 2:22pm #6

Phyma wrote:

Hello!

So I can't get custom images work for my cellphone. It works for the sample ones but it wont recognize my custom picture.

I have put in the App License Key and the picture show up in unity.

I have included all databases in the config, including my own.

Could the width that i upload the image with be a problem?

It wont even work if I take the astronaut picture, upload to the vuforia web and use that as image source for my project.

So what am i missing? The entire width when uploading picture is a mystery for me, so might be that.

 

All the standard vuforia things are enabled because the sample ones work.

Unity 2017.3.1f1,

Vuforia version dosent show in the VuforiaConfiguration but if i check the Help>>Vuforia>>Release Notes it show v7.0.47 notes. Might be this? But why do the sample imagetargetstill work?

 

I have been trying to fix this for hours, so I need all the help I can get.

 

Edit: Ohh Yeah no errors in unity or in the  Android Device Monitor. And cellphone Oneplus 3t Android 8.0.0. But the ImageTracking sample works so shouldnt be a version problem. or?

Are you using the Core Samples or a project you made? Can you share a screenshot of your Vuforia Configuration?

Thanks,

Vuforia Support

Custom target image doesnt work

February 21, 2018 - 2:22pm #5

diegop wrote:

Adding a license key it worked, thanks. But what doesnt work with or without license key is the ObjectTarget object using a OD file which worked fine in the scanner app.

There are many factors that can affect the tracking performance of a Object Target, both during the scanning process and when running an app. Most issues with Object Targets can be traced to the creation of the .od file using the Vuforia Object Scanner. Be sure to follow the scanner app instructions: https://library.vuforia.com/articles/Training/Vuforia-Object-Scanner-Users-Guide, paying close attention to step #8 in the article.

  • When creating the .od file, was the model scanned in an environment that was free of background details which may have introduced features that were not part of the model? Scanning in 'cluttered' environments can introduce false detection/tracking points.
  • When creating the .od file, were there any specular reflections on the model introduced by environmental lighting? Scanning objects that have reflective surfaces under direct lighting can introduce areas with no detection/tracking points.
  • Are you using the recommended devices referenced on the tool download page?: https://developer.vuforia.com/downloads/tool

In our labs, we utilize four primary strategies for creating an optimal Object Target scanning environment:

  • All background surfaces are colored at 18% gray. An easy, off-the-shelf solution is to buy bed sheets near this color and drape everything in the environment that could be seen by the scanning device's camera.
  • No direct lighting. We use light boxes and/or diffusers to eliminate direct lighting upon the object and minimize any spectral reflections.
  • Utilize a 360 turntable to re-orient the device. This is especially helpful when you've set your environment to near ideal conditions within a limited area. You can spin the model and scan in 360 degrees without having to move around it.
  • Be sure that the environment in which you’re testing (via the Object Scanner app ‘test mode’) is the same in which you’re verifying tracking (via the sample code). Environmental factors such as lighting, shadows, spectral reflections, etc. can negatively affect tracking performance, so awareness of how the environment is interacting with your model is important for qualifying performance.

Thanks,

Vuforia Support

Custom target image doesnt work

February 21, 2018 - 12:21pm #4

Hello!

So I can't get custom images work for my cellphone. It works for the sample ones but it wont recognize my custom picture.

I have put in the App License Key and the picture show up in unity.

I have included all databases in the config, including my own.

Could the width that i upload the image with be a problem?

It wont even work if I take the astronaut picture, upload to the vuforia web and use that as image source for my project.

So what am i missing? The entire width when uploading picture is a mystery for me, so might be that.

 

All the standard vuforia things are enabled because the sample ones work.

Unity 2017.3.1f1,

Vuforia version dosent show in the VuforiaConfiguration but if i check the Help>>Vuforia>>Release Notes it show v7.0.47 notes. Might be this? But why do the sample imagetargetstill work?

 

I have been trying to fix this for hours, so I need all the help I can get.

 

Edit: Ohh Yeah no errors in unity or in the  Android Device Monitor. And cellphone Oneplus 3t Android 8.0.0. But the ImageTracking sample works so shouldnt be a version problem. or?

Custom target image doesnt work

February 21, 2018 - 8:08am #3

Adding a license key it worked, thanks. But what doesnt work with or without license key is the ObjectTarget object using a OD file which worked fine in the scanner app.

Custom target image doesnt work

February 8, 2018 - 10:10am #2

Hello diegop,

Do you see any errors in the log? Did you put a license key in the Vuforia Configuration?

Thanks,

Vuforia Support

Log in or register to post comments