Log in or register to post comments

(De)Initialization issue with split files

March 18, 2018 - 6:52am #1

My app is quite large with a number of large 3D Models, so I have been try to publish a split file for android. 

I have followed the sticky instructions by creating a  pre-loading scene  to load the required xml and .dat files pre-vuforia initialization. 

a key point in these instructions is that it must all be done before Vuforia initializes. My issue lies in the fact that no matter what i try I can't prevent Vuforia from initializing before any other code executes.

To try stop the initializing, I have been through the typical solution:

  • delayed initialization selected, 
  • attach a vuforia behaviour to the camera and deactivate it. 

It all works fine in the unity editor, with the code executing in the right order (i.e. files copied and then vuforia initialized). Also, if the android application is not split, Vuforia does not initialize (as expected), however when split, Vuforia always initializes, regardless of the settings.  

I have tried this on an empty scene with a single camera in it, I simply can't find a way to prevent Vuforia from starting up. 

So my question is, are there any other options for preventing Vuforia from initializing when building for android? Is there something simple that I need to do that I'm missing? 

  I've tried the last two official releases of unity (currently 2017.3.1.f1 and Vuforia 7.0.47) with no luck. 

 

Log in or register to post comments