Log in or register to post comments

Delayed initialization not working as expected

November 10, 2017 - 3:36am #1

(Using Unity 2017.2 + Vuforia 6.5.22)

Not all scenes in this project need Vuforia (and device camera) so I'm trying to prevent Vuforia starting itself and creating "BackgroundPlane" object to all scene Cameras. "Delayed initialization" option is enabled in VuforiaConfiguration but Vuforia is still trying to start itself when the application is started.

How to reproduce:

  1. Create an empty Unity project (3D)
  2. Enable Vuforia in Player Settings -> XR Settings
  3. Enable "Delayed initialization" option in VuforiaConfiguration
  4. Run the project. You'll get an error:

Quote:

Vuforia cannot be started before it is initialized.

Please disable Delayed Initializationin the Vuforia configuration or initialize Vuforia manually with the VuforiaRuntime-class.

Any help how to prevent Vuforia trying to start itself automatically at application startup? Thanks!

Delayed initialization not working as expected

February 14, 2020 - 9:50am #8

We had used Delayed Initialization because there's only an optional subsection of our game that uses augmented reality, and we didn't need to present the camera permissions alert immediately. When the user chooses to enter the augmented reality scene, we first prompt for camera permissions. Once camera permissions are granted, the user enters the augmented reality scene. When the user enters that scene, we manually initialize Vuforia with VuforiaRuntime.Instance.InitVuforia();

However, now the camera permissions dialogue is presented immediately upon app launch, even though Vuforia is not initialized.

Delayed initialization not working as expected

February 12, 2020 - 1:06am #7

Hi @hololabs @maherahmedraza

Could you please elaborate on the issue? what does not work anymore?

What actions did you perform before the Delayed initialization that are now, not possible anymore? Would it be possible to get a log in which the issue has been reproduced?

Thank you.

Vuforia Engine Support

Delayed initialization not working as expected

February 11, 2020 - 12:12pm #6

Our team is also having issues with Delayed Initialization now. After updating Unity to 2019.3.0f6, Delayed Initialization no longer works. We updated from Vuforia 8.5.9 to 8.6.7 but the issue still persists.

Delayed initialization not working as expected

February 9, 2020 - 9:23am #5

I am using Unity 2019.3.0f5 and Vuforia 8.5.9. But the delayed initialization is not working I have checked the delayed initialization checkbox and i also disable the VuforiaBehaviour Script. After trying different solutions for several hours I decided to downgrade the version of Vuforia to 8.5.8. It didn't work on that one either. So I further downgrade it  to 8.3.9 and it worked. I don't know what is the problem. I think I have worked with Vuforia 8.5.8 few weeks back and the delayed initialization was working but at that time I had lower Version of Unity.. 

Delayed initialization not working as expected

January 29, 2019 - 1:58pm #4

Hello,

The article below isn't completely accurate. If you don't want to start into a Vuforia Engine AR experience, you can just start into a scene that does not have the Vuforia ARCamera in it.

Delayed initialization is only useful if you need to execute code before Vuforia is initialized, e.g. to fetch/uncrypt the Vuforia license key, set a driver library, or update the Vuforia Fusion provider.

https://library.vuforia.com/content/vuforia-library/en/articles/Training/vuforia-fusion-article.html

Thanks,

Vuforia Engine Support

 

Delayed initialization not working as expected

January 25, 2019 - 4:59am #3

Delayed initialization not working as expected

November 10, 2017 - 4:13am #2

Found a workaround for this from Unity forums: https://forum.unity.com/threads/do-not-run-vufory-when-the-application-starts.498351

Quote:

To disable Vuforia in a scene, you need to disable the Vuforia Behaviour.

To disable on the Main Camera, add a VuforiaBehaviour script from Component > Scripts > Vuforia in the menu.

Then disable (uncheck) that script component.

This way it's possible to keep "Delayed initialization" enabled and Vuforia doesn't try to start itself too early (before manual init).

Log in or register to post comments