Log in or register to post comments

Download a database without qcar folder, why ?

July 12, 2017 - 10:53pm #1

Hi, I`am very newbie in unity and vuforia and have a question:

I have an older database and this have a folder "Asset > Editor > QCAR > ImageTargetTextures > YourDB" and work perfectly.

But, now, I don`t have this folder when a database is downloaded, and the target don`t work.

What happend ? Please help !

Download a database without qcar folder, why ?

March 4, 2018 - 2:29am #8

For new version:

Editor->Vuforia->click on your image->reset (that is wheel above open)->drag image to image target

 

Regards

 

Download a database without qcar folder, why ?

September 9, 2017 - 2:00pm #7

This is an issue for us as well with Vuforia 6.2.6 and Unity 5.5.1p4.

The database (.unitypackage) now creates a 'Vuforia' folder in StreamingAssets and under the Editor folder where the images (.jpgs) and .dat, .xml containing the image targets are placed. These in fact need to be placed within the corresponding 'QCAR' folders in StreamingAssets and Editor, which the (.unitypackage) used to do automatically. This appears to be some kind of regression from how databases are exported from the TargetManager on Vuforia's website. Beware.

Download a database without qcar folder, why ?

July 24, 2017 - 3:09am #6

Hi,

i had the same issue. I found out, that the imported images in "Editor>Vuforia>ImageTargetTextures>*DATABASE NAME*" are defined as "Texture Shape -> Cube" in the Inspector. After changing to "2D" it works, without any copying of files. QCAR folders are not needed.

Download a database without qcar folder, why ?

July 17, 2017 - 12:37am #5

This work !!

I must be delete the .dat and .xml files and replaced.

really thank

Download a database without qcar folder, why ?

July 15, 2017 - 2:41pm #4

OK, I found a work around:

- Create a new project.

- Extract the Unity package into the new project.

- Navigate to the Editor>Vuforia>ImageTargetTextures>*DATABASE NAME*

- Right click on any of the images in that folder and select (Show in Explorer)

- Drag any new images to the Editor>QCAR>ImageTargetTextures>*DATABASE NAME* of your existing project

- Delete the .dat and .xml files located in the StreamingAssets>QCAR folder in your existing project

- Drag the new .dat and .xml files from the new project into the StreamingAssets>QCAR folder in your existing project.

After that, everything should work like it use to.

Download a database without qcar folder, why ?

July 15, 2017 - 2:25pm #3

I am experiencing the same issue. The Unity package use to throw all the images in the Editor>QCAR>ImageTargetTextures>*DATABASE NAME* folder, but now it creates a new folder in the Editor called Vuforia and throws everything in there. Also, it creates a new folder in the StreamingAssets folder called Vuforia and throws all the target data in that folder instead of the QCAR folder. I also get two errors regarding the .dat and xml files. Also, I don't see any new targets that I added to my database upon importing into Unity. Did you guys change the way the packages import?

AttachmentSize
Image icon VuforiaImportError.png23.73 KB

Download a database without qcar folder, why ?

July 13, 2017 - 12:06pm #2

Hello para3lso,

That missing folder should not be causing the targets to not be detected. Could you open your Vuforia Configuration and make sure your dataset is loaded and activated?

Thanks,

-Vuforia Support

Log in or register to post comments