Log in or register to post comments

error messages with vuforia 7.5.20 and 7.5.26

October 30, 2018 - 9:27am #1

Hi

Im a bit confused about the best way to update vuforia and unity, I read somewhere today that 2018.2 is the only version that will allow updates to the very latest version.

I got the latest unity hub which is 1.2.0, this is how I am installing unity and then vuforia

if I install unity 2018.1.9f1 then vuforia 7.1.35 comes as default and it offers an update to 7.2.23 (see attached) if you click on vuforiaConfiguration twice (doesnt work first time).

if I download this update then run the installer it fails (see attached)

if I install unity 2018.2.14 then it comes with vuforia 7.5.20 which in my older scene (which until today worked fine on unity 2018.1.9f1 and vuforia 7.2.23) then it throws errors relating to custom/videoBackground and CloudErrorHandler (see attached)

If anyone could help that would be great, Ive spend the whole day installing different versions of things trying to get vuforia updated so It runs better on as many ARcore devices as possible (which the newer versions promise)

best

Tom

error messages with vuforia 7.5.20 and 7.5.26

December 4, 2018 - 3:40am #8

Marc Im curious about 

Quote:

I was able to build it in xcode sucessfully, BUT i could not test it on my iPhone 8 plus since i updated it to version 12 not long ago :(

Im guessing its an ios 12 problem?

error messages with vuforia 7.5.20 and 7.5.26

December 4, 2018 - 3:07am #7

thanks Marc that really helped me with my own fixing, Im currently just working my way through the process.

error messages with vuforia 7.5.20 and 7.5.26

November 14, 2018 - 7:46am #6

Hi, I just followed the steps to update vuforia to 7.5.26 and I'm using unity 2018.2.15f1 ... and I'm still getting the error

 

*** latest news upate *** :)

Ok, so after some reading, a couple of brain cells that poped, I found a cure :)

here's what i did...

in the CloudRecoEventHandler.cs script file..

in void Update()

change : SetCloudActivityIconVisible(m_ObjectTracker.TargetFinder.IsRequesting());

to : SetCloudActivityIconVisible(m_ObjectTracker.GetTargetFinder<TargetFinder>().IsRequesting());

 

change the public void OnInitialized()

to : public void OnInitialized(TargetFinder targetFinder)

and change this line : m_TargetFinder = m_ObjectTracker.TargetFinder;

to m_TargetFinder = m_ObjectTracker.GetTargetFinder<TargetFinder>();

 

THEN

in the CloudErrorHandler.cs file...

change public void OnInitialized() to public void OnInitialized(TargetFinder targetFinder)

 

VOILA!!! that got rid of all the error messages

I was able to build it in xcode sucessfully, BUT i could not test it on my iPhone 8 plus since i updated it to version 12 not long ago :(

 

Cheers!!

Marc.

AttachmentSize
Image icon vuforia Error CS0535.jpeg57.21 KB

error messages with vuforia 7.5.20 and 7.5.26

November 1, 2018 - 4:57am #5

Hi Medabit thanks so much for your help

I'll try this as soon as I can but might be a week or two now.

we branched off from the sample scene a while ago, so I guess we can expect these things to happen every now and then? thats OK now I figured out how to deal with installing different vuforia engine versions

best

Tom

error messages with vuforia 7.5.20 and 7.5.26

October 31, 2018 - 11:03am #4

Hello,

These errors are typically related to the samples being misaligned with the SDK version (i.e. samples version < SDK version).

  • `CloudRecoEventHandler' does not implement interface member `Vuforia.ICloudRecoEventHandler.OnInitialized(Vuforia.TargetFinder)'
    • In this case, this was an intended API change where the community was not informed. The 7.5 samples correctly uses the new API, so the issue here was specifically related to documentation.
    • I've attached the 7.5.26 version of the script for reference
  • Unable to find shader Custom/VideoBackground UnityEngine.Debug.LogErrorFormat(String, Object[])
    • You can workaround this issue by:
      • Delete the Vuforia directory under "Assets" folder
      • Creating a Vuforia game object
    • This will force Unity to re-import Vuforia, and the error should go away

Hope this helps.

Thanks,

Vuforia Engine Support

AttachmentSize
Package icon CloudRecoEventHandler.cs_7.5.zip1.98 KB

bugs with vuforia 7.5.20 and 7.5.26

October 30, 2018 - 9:52am #3

Hi

 

our codebase doesnt throw errors with these

unity 2018.1.9f1 + vuforia 7.2.23 

unity 2018.2.14f1 + vuforia 7.2.23

so I think that removes unity or unity hub from the equation?

 

upgrading either of those unity versions to vuforia 7.5.20 or 7.5.26 will throw the errors

see attached

best

Tom

bugs with vuforia updates / unity hub

October 30, 2018 - 9:31am #2

I just found this sticky thread, which I think hopefully solves my problem updating vuforia using unity hub

https://developer.vuforia.com/forum/unity/updating-vuforia-version-when-using-unity-hub

Im going to try this.

but still this doesnt fix my other problems with newer versions, I get those error messages with 7.5.20 and 7.5.26

thanks

Log in or register to post comments