Log in or register to post comments

Error pushing camera intrinsics to VIO

October 31, 2018 - 8:25am #1

Hello,

we are using Unity 2017.2.1f1 for a while now with Vuforia 6.5.25.
Now we wanted to upgrade to Unity 2018.2.12 and we get an error in xCode 10.1:

2018-10-31 15:54:16.385795+0100 Project[6849:2369649] [Technique] Error pushing camera intrinsics to VIO: (1630.557129, 0.000000, 957.844055)
(0.000000, 1630.557129, 527.630676)
(0.000000, 0.000000, 1.000000)
>, Calibrated Intrinsics: (1481.628174, 0.000000, 959.500000)
(0.000000, 1476.246460, 539.500000)
(0.000000, 0.000000, 1.000000)
>
2018-10-31 15:54:16.403399+0100 Project[6849:2369649] [Technique] Error pushing camera intrinsics to VIO: (1630.557129, 0.000000, 957.844543)
(0.000000, 1630.557129, 527.677673)
(0.000000, 0.000000, 1.000000)
>, Calibrated Intrinsics: (1481.628174, 0.000000, 959.500000)
(0.000000, 1476.246460, 539.500000)
(0.000000, 0.000000, 1.000000)
>
2018-10-31 15:54:16.418964+0100 Project[6849:2369649] [Technique] Error pushing camera intrinsics to VIO: (1630.557129, 0.000000, 957.852417)
(0.000000, 1630.557129, 527.639038)
(0.000000, 0.000000, 1.000000)
>, Calibrated Intrinsics: (1481.628174, 0.000000, 959.500000)
(0.000000, 1476.246460, 539.500000)
(0.000000, 0.000000, 1.000000)
>
and so on...

This error doesn't appear immediately. Sometimes after a few seconds, sometimes later and then it fills the console window (appears every frame).
Also there is a grey 1px Frame around the camera image, flickering vor a few seconds. Not sure though if it is related to the error message.

Then we tried the last Unity 2017 version (2017.2.14) with Vuforia 7.5.20. There the error also appears. The camera image is different. The grey frame is thicker (about 10px) and stays (doesn't flicker).

We tried different graphics api settings and also Unity 2018.2.13 and 2018.2.14.

Any help would be much appreciated!
Thanks!

Error pushing camera intrinsics to VIO

September 6, 2019 - 2:48am #11

Problem still remaining using Unity 2018.3.0f2 with XCode 10.3 (10G8) and Vuforia 8.1.10

Camera is enabled and is filming. The tracking works, but the videoBackground is black. Maybe, it's not related, but still.

Any idea?

THX

Error pushing camera intrinsics to VIO

March 5, 2019 - 3:08pm #10

same issue anybody has a solution ? 

I am trying to build simple model target demo with 6 views.

Error pushing camera intrinsics to VIO

February 19, 2019 - 7:00pm #9

We are having the exact same issue:

 

Unity 2018.3.3f1

Xcode: 10.1

 

 

Error pushing camera intrinsics to VIO

January 17, 2019 - 2:12am #8

The frame seems to be fixed in v8.0.10. The Vuforia release changes also say it is fixed.

I still get the error message but seems to be unrelated.

Error pushing camera intrinsics to VIO

November 30, 2018 - 1:00am #7

So far I tried only on iPhone 7, iOS 12.1.
I also tried the Vuforia Astronaut Demo and the Error also appears. But there I don't have the problem with the grey frame.
Could you find out anything?

Thanks.

Error pushing camera intrinsics to VIO

November 6, 2018 - 9:47am #6

Hello,

It could also be a Unity issue as they perform rendering.

Looks like Xcode 10.1 was released on 10/30/18. I think previously you were using a beta version.

Is there a particular device or devices that you're observing this on? If so, now that Xcode 10.1 is officially released, I can try to replicate.

Thanks,

Vuforia Engine Support

Error pushing camera intrinsics to VIO

November 1, 2018 - 9:21pm #5

Hello,

it works fine on Android. No error messages and no grey border around the camera image.

For me it seems like it is a Vuforia problem. It doesn't happen in 2017.2.1 but in 2017.4.14 and later.

Thanks

 

Error pushing camera intrinsics to VIO

November 1, 2018 - 11:41am #4

Hello,

Unfortunately, I don't see anything obvious.

Have you tried on another device? Android?

Thanks,

Vuforia Engine Support

Error pushing camera intrinsics to VIO

October 31, 2018 - 11:27pm #3

Hello,

thanks for the quick reply.
It looks like ARKit is being used. Below is the beginning of our log output.
Do you see anything related to our bug?
Any idea if it is related to the grey Frame around the camera image?

Thanks!

2018-11-01 07:14:03.326129+0100 Project[7146:2475118] [DYMTLInitPlatform] platform initialization successful
W1101 07:14:04.834009 1 commandlineflags.cc:1311] Ignoring RegisterValidateFunction() for flag pointer 0x10782f0f0: no flag found at that address
2018-11-01 07:14:04.926987+0100 Project[7146:2474931] Built from '2018.2/release' branch, Version '2018.2.14f1 (3262fb3b0716)', Build type 'Development', Scripting Backend 'il2cpp'
2018-11-01 07:14:04.939243+0100 Project[7146:2474931] -> registered mono modules 0x107224dd0
-> applicationDidFinishLaunching()
PlayerConnection initialized from /var/containers/Bundle/Application/7EDB0816-0AC6-4939-A730-AAC048F35533/Project.app/Data (debug = 0)
PlayerConnection initialized network socket : 0.0.0.0 55000
Multi-casting "[IP] 10.160.230.30 [Port] 55000 [Flags] 2 [Guid] 4125589585 [EditorId] 4035805232 [Version] 1048832 [Id] iPhonePlayer(iPhone):56000 [Debug] 0 [PackageName] iPhonePlayer" to [225.0.0.222:54997]...
Started listening to [0.0.0.0:55000]
PlayerConnection already initialized - listening to [0.0.0.0:55000]
2018-11-01 07:14:05.146031+0100 Project[7146:2474931] Metal GPU Frame Capture Enabled
2018-11-01 07:14:05.147516+0100 Project[7146:2474931] Metal API Validation Disabled
2018-11-01 07:14:05.506760+0100 Project[7146:2474931] [Warning] Trying to set delaysTouchesBegan to NO on a system gate gesture recognizer - this is unsupported and will have undesired side effects
-> applicationDidBecomeActive()
Renderer: Apple A10 GPU
Vendor: Apple Inc.
Version: OpenGL ES 2.0 Metal - 58.3
GLES: 2
GL_OES_depth_texture GL_OES_depth_texture_cube_map GL_OES_depth24 GL_OES_element_index_uint GL_OES_fbo_render_mipmap GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_vertex_array_object GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_draw_instanced GL_EXT_instanced_arrays GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_pvrtc_sRGB GL_EXT_read_format_bgra GL_EXT_separate_shader_objects GL_EXT_shader_framebuffer_fetch GL_EXT_shader_texture_lod GL_EXT_shadow_samplers GL_EXT_sRGB GL_EXT_texture_filter_anisotropic GL_EXT_texture_rg GL_EXT_texture_storage GL_APPLE_clip_distance GL_APPLE_color_buffer_packed_float GL_APPLE_copy_texture_levels GL_APPLE_framebuffer_multisample GL_APPLE_rgb_422 GL_APPLE_sync GL_APPLE_texture_format_BGRA8888 GL_APPLE_texture_max_level GL_APPLE_texture_packed_float GL_IMG_r
ead_format GL_IMG_texture_compression_pvrtc
OPENGL LOG: Creating OpenGL ES 2.0 graphics device ; Context level ; Context handle -2097016320
Initialize engine version: 2018.2.14f1 (3262fb3b0716)
WARNING: RGBA Compressed ASTC6X6 UNorm format is not supported, decompressing texture
WARNING: RGBA Compressed ASTC6X6 UNorm format is not supported, decompressing texture
WARNING: RGBA Compressed ASTC4X4 UNorm format is not supported, decompressing texture
UnloadTime: 1.767166 ms
Compiled for iOS
UnityEngine.DebugLogHandler:Internal_Log(LogType, String, Object)
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
UnityEngine.Debug:Log(Object)
Vuforia.PlatformRuntimeInitialization:InitPlatform()

(Filename: /Users/builduser/buildslave/unity/build/Runtime/Export/Debug.bindings.h Line: 43)

Initializing Vuforia
UnityEngine.DebugLogHandler:Internal_Log(LogType, String, Object)
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
UnityEngine.Debug:Log(Object)
Vuforia.VuforiaRuntime:InitVuforia()
Vuforia.VuforiaRuntime:VuforiaInitialization()

(Filename: /Users/builduser/buildslave/unity/build/Runtime/Export/Debug.bindings.h Line: 43)

Vuforia SDK Version: 7.5.20
UnityEngine.DebugLogHandler:Internal_Log(LogType, String, Object)
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
UnityEngine.Debug:Log(Object)
Vuforia.VuforiaRuntime:LogVersions()
Vuforia.VuforiaRuntime:InitVuforia()
Vuforia.VuforiaRuntime:VuforiaInitialization()

(Filename: /Users/builduser/buildslave/unity/build/Runtime/Export/Debug.bindings.h Line: 43)

Vuforia Unity Extension Version: 7.5.20
UnityEngine.DebugLogHandler:Internal_Log(LogType, String, Object)
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
UnityEngine.Debug:Log(Object)
Vuforia.VuforiaRuntime:LogVersions()
Vuforia.VuforiaRuntime:InitVuforia()
Vuforia.VuforiaRuntime:VuforiaInitialization()

(Filename: /Users/builduser/buildslave/unity/build/Runtime/Export/Debug.bindings.h Line: 43)

Unity Editor Version: 2018.2.14f1
UnityEngine.DebugLogHandler:Internal_Log(LogType, String, Object)
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
UnityEngine.Debug:Log(Object)
Vuforia.VuforiaRuntime:LogVersions()
Vuforia.VuforiaRuntime:InitVuforia()
Vuforia.VuforiaRuntime:VuforiaInitialization()

(Filename: /Users/builduser/buildslave/unity/build/Runtime/Export/Debug.bindings.h Line: 43)

Unloading 5 Unused Serialized files (Serialized files now loaded: 0)
Initializing Vuforia...
2018-11-01 07:14:09.736777+0100 Project[7146:2474931] [MC] System group container for systemgroup.com.apple.configurationprofiles path is /private/var/containers/Shared/SystemGroup/systemgroup.com.apple.configurationprofiles
2018-11-01 07:14:09.737924+0100 Project[7146:2474931] [MC] Reading from public effective user settings.
2018-11-01 07:14:09.743829+0100 Project[7146:2474931] Requesting access to the camera
2018-11-01 07:14:13.502435+0100 Project[7146:2475159] User granted access to the camera
2018-11-01 07:14:13.502691+0100 Project[7146:2474931] INFO/AR(7146) 2018-11-02 07:14:13: Vuforia selected rendering API OpenGL ES 2.x
2018-11-01 07:14:13.502720+0100 Project[7146:2474931] INFO/AR(7146) 2018-11-02 07:14:13: Vuforia SDK version 7.5.20
2018-11-01 07:14:13.645577+0100 Project[7146:2474931] INFO/AR(7146) 2018-11-02 07:14:13: Matched precache profile for Apple, iPhone9,3, iOS 12, 750.1
2018-11-01 07:14:14.669050+0100 Project[7146:2474931] INFO/AR(7146) 2018-11-02 07:14:14: Vuforia Fusion: Detected and enabled use of ARKit
2018-11-01 07:14:14.669500+0100 Project[7146:2474931] Rendering mode set to: OpenGL ES 2.0
2018-11-01 07:14:14.787230+0100 Project[7146:2474931] Rendering mode set to: OpenGL ES 2.0
2018-11-01 07:14:14.798942+0100 Project[7146:2474931] DEBUG/AR(7146) UIView has CAEAGLLayer layer class
2018-11-01 07:14:14.799115+0100 Project[7146:2474931] DEBUG/AR(7146) UIView does not respond to selector renderFrameVuforia
2018-11-01 07:14:14.799305+0100 Project[7146:2474931] DEBUG/AR(7146) UIView has CAEAGLLayer layer class
2018-11-01 07:14:14.799389+0100 Project[7146:2474931] DEBUG/AR(7146) UIView does not respond to selector renderFrameVuforia
2018-11-01 07:14:14.799457+0100 Project[7146:2474931] DEBUG/AR(7146) Could not find a UIView with CAEAGLLayer or CAMetalLayer layer class that responds to selector renderFrameVuforia
2018-11-01 07:14:14.812571+0100 Project[7146:2474931] [Common] _BSMachError: port 12b03; (os/kern) invalid capability (0x14) "Unable to insert COPY_SEND"
2018-11-01 07:14:14.814105+0100 Project[7146:2474931] [Common] _BSMachError: port 12b03; (os/kern) invalid capability (0x14) "Unable to insert COPY_SEND"
System memory in use before: 12.5 MB.
System memory in use after: 12.7 MB.

Error pushing camera intrinsics to VIO

October 31, 2018 - 1:50pm #2

Hello,

This doesn't look like a Vuforia message - wonder if it is coming from ARKit?

Vuforia 7.X should emit a log message indicating whether ARKit is being used or not (I know it definitely exists in the later versions of Vuforia 7.X, just not sure about 7.0.X).

Thanks,

Vuforia Engine Support

Log in or register to post comments