Log in or register to post comments

Failing to track in 2019.4.1f1

January 9, 2021 - 5:42pm #1

Hello,

Context for my experience: I've been using Vuforia for awhile, successfully. I understand how it works, generally, and I've done three projects now using it.

The issue: 

The project I'm working on currently is having some issues with Vuforia. Tracking is inconsistent and has not been stable at all. I'm unsure what I've done wrong, and would appreciate some help troubleshooting this.

While tracking an image (this happens successfully), the model placed on the image is not being properly rotated or positioned. It feels as though it loses tracking every couple frames. I'm using a simple Cube right now to test, so the geometry is minimal. My tracking image that I'm using is also 5 stars, so that doesn't seem to be the issue either. I've tested this with several images that I've used in the past, with all the same results. I've also tried increasing the frame rate of the camera to stabilize the tracking consistency, thinking that it just wasn't fast enough for my phone (Google Pixel 4 XL), and this caused jittering and did not improve tracking. I tried enabling VSync, but saw no difference.

This is a VERY simple setup and does not have any niche properties. I tried following a tutorial for Vuforia in a new project, updated to 2020.9, and saw the exact same problem. I installed Vuforia using the link from the Downloads section, which leads to the asset store. I then imported using Package Manager. I have Git installed on my PC.

Quality settings

https://i.gyazo.com/f3331039ac222e661bd7779512f4913e.png 

Render settings:

{

https://gyazo.com/0233268da008a5aa2aa2fbf217f4af38

https://gyazo.com/5ecd13421c795e5f33803c5cbc672d40

}

Vuforia config:

https://i.gyazo.com/c2347016e69d8ecf81770f4b9ac47935.png

Failing to track in 2019.4.1f1

January 22, 2021 - 11:00am #3

We are seeing the same issues and  I can verify that Vuforia is broken for image trackers with device or ground plane tracking. Our company has reached out repeatedly and reported to Vuforia along with  detailed information and examples starting in October, it was not prioritized by them as it was considered an edge case.

Failing to track in 2019.4.1f1

January 19, 2021 - 5:39am #2

Hi,

Could you please let us know the following?

1. Vuforia SDK version?

2. Features in which you see the lack of tracking? -> Image Targets? Model Targets?

3. Would it be possible to test out our Core sample app and let me know if you observer the same behaviour?

 

Thank you.

Vuforia Engine Support

Log in or register to post comments