Log in or register to post comments

Feed from webcam not showing

October 14, 2019 - 6:12am #1

Hi all,

First of all: I have Vuforia 8.3.9 installed on Unity 2019.2.8f1. It's a fresh installation of Windows.

I tried to create an ARCamera on the project. When it's running, I can see just what the camera in 3D viewport is seeing.

ARCamera has a VideoBackground child game object that, in the material preview, is showing the webcam feed.

I also get an error saying "Unable to start ObjectTracker. Your hardware many not support it".

The webcam is an integrated, generic webcam

 

I'm kinda lost and I don't know what to do. I think this is something that happens to many people because I saw people complaining on other forums (and even here!) and coming up with various solutions that turned out good for them but didn't for me. Is there some step-by-step troubleshooting for this?

 

Kind regards,

Marco

Feed from webcam not showing

October 16, 2019 - 6:01am #3

Hi,

Please install the recommended drivers from the manufacturer, else windows will use the generic drivers which work but not ideal.

Yes, some people are encountering issues with webcams but the causes are quite different, related usually to OS.

The behavior that you came across is just a black screen after you hit play?

One things that could be is to check in the settings if the VideoBackground is enabled. Could you please check and confirm? ( In the Vuforia configuration settings, please make sure that Enable VideoBackground is checked)

Thank you.

Vuforia Engine Support

 

Feed from webcam not showing

October 14, 2019 - 10:40am #2

Update: I also tried with a recognised camera (one present in the xml) and it doesn't work

Log in or register to post comments