Log in or register to post comments

Front camera freezes and black screen

June 5, 2018 - 9:31pm #1

We are using Vuforia inside Unity 3D. In recent weeks we have the recurring problems (listed below) when we upgrade the tools (either Vuforia, Unity, or Xcode). 

1. Front camera freezes using Unity 2018.1.1f1 and Vuforia 7.1.34 on iPhone devices that support ARKit with iOS 11.3.1. We have solved it by delaying few seconds before initialization of camera. We just would like to make sure for the next update we can do front camera without having to search for another trick.

2. Black screen on the iPhones that support ARKit with latest iOS version. Four weeks ago we had a problem that it did not work on iPhone 6S and above with iOS 11.3.0. And then we downgraded the Xcode 9.2 and got it working. Then iOS updates to 11.3.1 and we found that it doesn't work again. We have upgraded the Vuforia, Unity, and Xcode to the latest version and it still doesn't work. But on iPads ARkit enabled with iOS 11.3.1 it works. The problems always only on newest iPhones only (most of the time iPhone X). Would Vuforia be able to identify for every iOS release which version of Vuforia that works to match which version of Unity and Xcode, and support what devices?

Front camera freezes and black screen

June 7, 2018 - 9:50am #2

Hello octagonstudio,

When does the freeze happen with the front camera? I'm not able to reproduce this using Vuforia 7.1.34, Unity 2018.1, and an iPhone X running iOS 11.3. Are you able to reproduce this within the sample apps?

The black screen issue is documented in this thread: https://developer.vuforia.com/forum/ios/resolution-vuforia-7-ios-113-black-screen-problem

You'll need to run 7.1.34 when using iOS 11.3 and XCode 9.3. iOS 11.2 + XCode 9.2 should work on any version of Vuforia.

Thanks,

Vuforia Support

Log in or register to post comments