Topic locked

how properly upgrade from 8.1 to 9?

December 14, 2020 - 11:20am #1

I'm trying to upgrade a project of mine that currently uses vuforia 8.1

 

If I download unitypackage from vuforia's site I get:

 

An error occurred while resolving packages:

  Package

has invalid dependencies:

    com.unity.ugui: Package [com.unity.ugui@1.0.0] cannot be found <---- makes sense, project is with unity 2018.3.7f1

A re-import of the project may be required to fix the issue or a manual modification of J:/unities/vatra9/Packages/manifest.json file.

Unable to parse file Packages/com.ptc.vuforia.engine/Vuforia/Plugins/OSXUniversal/FileDriver.bundle.meta: [did not find expected key] at line 15

Unable to parse file Packages/com.ptc.vuforia.engine/Vuforia/Plugins/iOS/ARFoundationDriver.framework.meta: [did not find expected key] at line 15

Assembly has reference to non-existent assembly '' (Packages/com.ptc.vuforia.engine/Tests/Editor/VuforiaPackageTests.asmdef)

Unable to parse file Packages/com.ptc.vuforia.engine/Vuforia/Plugins/Win64/FileDriver.dll.meta: [did not find expected key] at line 14

 

Does vuforia 9 only works with a specific unity version?

how properly upgrade from 8.1 to 9?

December 18, 2020 - 11:40am #4

Thanks @mcotora, fresh version with 9.6 works with samples. Have to do some manual adjustments to get proejct back to work, should be ok.

how properly upgrade from 8.1 to 9?

December 17, 2020 - 3:18pm #3

After the update, several handlers and namespaces from the samplesResources are no longer being recognized by unity, is there anyway to fix this?

AttachmentSize
Image icon image.png66.25 KB

how properly upgrade from 8.1 to 9?

December 15, 2020 - 3:18am #2

Hi,

Yes, we support 2019.4 LTS+ with 9.4.

In your case you will need to upgrade to at least 2019.4 for 9.6.

Thank you.

Vuforia Engine Support

Topic locked