Log in or register to post comments

How to stop Vuforia Behavior

October 28, 2017 - 2:30pm #1

I have three scenes in my project.

First one is just a Main Menu.

Seconde one is a Virtual Reality Scene using GoogleVR

Third one is a AR Scene using vuforia.

Not sure why, but when I started VR Scene (Not AR), vuforia behavior is loaded too and it changed my field of view.

There is a way to prevent vuforia to start when app is loaded and just start when I load AR Scene?

I tried this but not worked.

public void stopAR(){

  if (Vuforia.CameraDevice.Instance.IsActive()) {

   Vuforia.CameraDevice.Instance.Deinit ();

   Vuforia.CameraDevice.Instance.Stop ();

   Debug.Log ("AR Stopped");

  }

}

 

 

Thanks

[Solved] How to stop Vuforia Behavior

October 30, 2017 - 11:16am #3

Thanks a lot. It solved my problem.

For someone who has the same issue:

Add a script on Mail Camera where you do NOT want vuforia to start.

Add VuforiaBehavious Script.

Uncheck it.

Done.

How to stop Vuforia Behavior

October 30, 2017 - 8:58am #2

Hello larocca,

This thread over on our Unity subforum goes over the solution to the issue you're having: https://forum.unity.com/threads/do-not-run-vufory-when-the-application-starts.498351/

Thanks,

-Vuforia Support

Log in or register to post comments