Log in or register to post comments

How to turn off Extended tracking

December 2, 2020 - 2:20am #1

Hi All.

I have updated my app into new Unity(2019.4.10f) and new Vuforia(9.6.3).

In my app i have Cloud recognition and Ground tracking(different scenes).  To make ground tracking work, I have to turn on the "Track Device Pose" in Vuforia configuration(image attached). But in this case Marker tracking works like Extended. Even if I chose Tracking mode to "Tracked",  it will works as Extended.(image attached)

Is this a bug?  If no, then how can i solve this problem.  I need marker tracking to be stable(as stable as possible :) )



Thanks.

AttachmentSize
Image icon Track Device Pose15.36 KB
Image icon Tracking mode13.28 KB

How to turn off Extended tracking

January 5, 2021 - 7:02am #5

Hi @art1997,

I tested the behaviour with the Core sample app-> Cloud Reco Scene. I left the Device Tracker on in the Configuration file and changed the Status Filter of the Cloud Trackable Event Handler to Tracked.

With the above configuration I was *not* able to reproduce the behaviour mentioned by you. Extended tracking was off for the specific GameObject.

I noticed that you use for Cloud Reco the DefaultTrackableEventHandler, could you please try it with CloudTrackableEventHandler? as we demo it in the coresample.

Thank you.

Vuforia Engine Support

How to turn off Extended tracking

December 25, 2020 - 12:07pm #4

Hi, I have a similar issues * sometimes *. I am as well using 9.6.3 can't reproduce bug contantly but it does "stick" targets AR.Tracking mode is set per object (cylindircal targets in my case).

How to turn off Extended tracking

December 2, 2020 - 10:10pm #3

@mcotora As you can see i have attached images, where I have set that already.  But tracking still goes as extended.  Please ask this to Dev team, maybe it is a bug.

Thanks.  

How to turn off Extended tracking

December 2, 2020 - 8:20am #2

Hi,

You can turn off and on extended tracking on per target basis by changing the status to Tracked.

Under DefaultTrackableEventHandler -> Consider target is visible if status is: (under the drop-down menu change it to) Tracked

Hope it helps.

Vuforia Engine Support

Log in or register to post comments