Log in or register to post comments

Image Target sometiems not recognized if not put out of screen first

January 17, 2018 - 7:58am #1

Hi, i'm building an AR app in unity 2017.3, vuforia v7.0.43

I have some Image targets which are very good according to the target manager, in fact, most of the times, once the target is in the frame, the trackable is recognized instantly. However, there is a substantial number of times (i'd say circa 20-30% of the times i tried) when the marker is in the frame, perfectly zoomed and focused, but the app does not recognize it, and regardless of how much i stare at it, or move the camera around, it won't be recognized unless i move the phone so that the target is completely off screen, and then point to it again.

is there a way to avoid this behaviour?

 

Image Target sometiems not recognized if not put out of screen first

January 17, 2018 - 8:58am #2

This is how Vuforia has always worked.  Sometimes it needs to be "reset" by looking away.  I've never tried to find a fix (it was never as much of an issue for my projects).  Maybe you could try to fix in code, not sure if it will work though.  Keep track if you are currently tracking a target, if not, stop and start the tracker on a periodic interval.   Maybe this will reset the tracker and it will see it, not sure.  That being said, 20-30% seems awfully high for this issue.  Wondering if something else is at play here.  Try the Vuforia samples to see if you get such a high percentage and rule out if it is something you may be doing in your project.







 

Log in or register to post comments