Topic locked

ImageTarget not recognized at all?

June 30, 2021 - 8:44am #1

So long story short (I hope someone can help me, I feel like I tried everything)

 

I'm new to Vuforia and Unity AR, so I tried a few (video) tutorials to use Vuforia and create an image target.

I created an Vuforia account and downloaded the latest version for unity (add-vuforia-package-9.8.8.unitypackage). After that I imported that package and created a license key. I added an AR Camera in the unity hierarchy with Rightclick and selecting Vuforia Engine -> AR Camera. I added the license key by selecting "Open Vuforia Engine configuration" and pasting the license key into "App License Key".

I created an ImageTarget by right-clicking in hierarchy again (Vuforia Engine -> Image Target). I set the settings in the inspector and add a simple sphere as child.

Please take a look at the screenshots. They will show the configuration a little clearer. I'm not even using my own image targets yet.

So after all this whenever I try to start it by clicking the Play-button in Unity my webcam turns on and I can see myself. But while holding the printed image targets up to the camera, nothing changes and there is no sphere whatsoever.

I tried without sphere, but instead with Planes or .fbx models. Nothing shows up.

Anyone any idea? I'm really freaking out because everyone else, following the tutorials, seem to have no issues.

 

PS: I also tried InstantImage after nothing else worked. Still same results.

ImageTarget not recognized at all?

July 18, 2021 - 7:49am #6

Well done with this article! fall guys

ImageTarget not recognized at all?

July 7, 2021 - 4:09am #5

Fyi: I tried another camera and it worked. Same settings, same location, same hardware. Maybe there are some issues with some kinds of webcams. I'm still trying to figure out.

ImageTarget not recognized at all?

July 6, 2021 - 11:59am #4

Hi,

I read again the issue and all steps seem to be correct, no Idea what is the reason -  it is strange.

Possibly you can try another approach -> so you try to test the Vuforia Core Example  So go to the Assets/SamplesResources/Scenes/3-ImageTargets

Add first in the Vuforia configuration your license and test the scene with the target in the directory  Assets\Editor\Vuforia\ForPrint\ImageTargets

So will this work. Later you can copy this scene and modify it and check if it is still working.

BR

Vuforia Engine Support

ImageTarget not recognized at all?

June 30, 2021 - 1:29pm #3

Thanks for the reply :) I really appreciate the help!

But apparently it doesn't work either. I adjusted the width a little bit, but it was already very accurate (see new files below).

Maybe any other idea?

AttachmentSize
Image icon Advanced Settings286.79 KB
Image icon Augmentation Transform18.08 KB
Image icon Unity Play Mode634 KB

ImageTarget not recognized at all?

June 30, 2021 - 1:07pm #2

Hi ,

please, check in the Advance tab of the Image Target Behavior script the size of your image target. It is in meter:

Also you need to check the size of the augmentation - the x,y and z scale factor. Possibly a very large or very small scale factor will cause that you could not see the augmentation

For example if your target with is 60  and scale of the augmentation is 015 - you will not see the augmentation because it will be very tiny.

Otherwise if you Image size is 0.06 and the Astronaut scale is 15 - you will not see anything because the augmentation is to large.

BR

Vuforia Engine Support

 

 

AttachmentSize
Image icon 2021-06-30_21-59-05.jpg84.88 KB
Image icon 2021-06-30_22-01-34.jpg85.92 KB
Topic locked