Log in or register to post comments

Including ARCore Library for Extended Tracking causes camera focus issues

October 3, 2020 - 12:49pm #1

I'm currently using Unity to make an AR app that relies on both image tracking and GPS, depending on the scene. I'm using Unity 2019.4.1f1 and Vuforia 9.4.6, as well as the Unity package AR + GPS Location for GPS based scenes. Following basic setup instructions for the GPS scenes, within the VuforiaConfiguration, I enabled Track Device Pose and set the ARCore Requirement to optional. However, the GPS scenes won't render the tracked object unless I also check the box to Include ARCore Library. But when I check that box, my other scenes that rely on image tracking won't work because the Android camera isn't able to focus itself. If I uncheck that box (not including the ARCore library) then my image tracking scenes work just fine with perfect camera focus, which makes me think that this is an issue within my VuforiaConfiguration rather than my AR + GPS Location configuration.

I've also tried checking the box to include the ARCore library and setting the ARCore requirement in code (only required in GPS scenes and disabled in image tracking scenes), and I'm still having the same issue. I don't have the ARCore library (or AR Foundation) installed through the Unity Package Manager. I've been digging through documentation and forum posts and can't find anything similar.

Edit: In my build settings, my target API level and my minimum API level are both set to API level 29.

Including ARCore Library for Extended Tracking causes camera focus issues

October 5, 2020 - 6:37am #2

Hi,

Extended tracking requires the ARCore to work, hence you will need to have it checked in the Vuforia config.

Have you tried setting the camera to autofocus? We have this set up as an UI option, script: MenuOptions.cs in our Core Sample app for reference, scene: Image Targets

Thank you.

Vuforia Engine Support

 

Log in or register to post comments