Log in or register to post comments

macOS, 2019.3.0f5 : Crash on play

March 10, 2020 - 5:02pm #1

Hello,

I've been struggling to get Vuforia 8.6.10 to work with Unity 2019.3.0f5. Unity crashes when clicking on the play mode button, every time. I've tried with a new project, a project that had already been built before, and Vuforia's sample project from the asset store. I can't get any of them to work.

I'm using Unity and Vuforia on a 2019 MacBook Pro, running macOS Catalina 10.15.2.

I've tried checking camera permissions, but I can't find Unity or Unity Hub in the camera permissions list, nor did Unity ever asked me for such permissions (and it was working before !). I've also tried using OpenGL instead of Metal, both for the Unity Editor and the target build, that didn't work either. Building and running on iOS also ends up in a crash right away. I've tried a lot of things, using these forums, stackoverflow, and the Unity forums, to no avail.

I've attached the macOS crash log.

AttachmentSize
Plain text icon crashlog.txt172.98 KB

macOS, 2019.3.0f5 : Crash on play

March 11, 2020 - 1:27am #2

Update : Turns out the iOS target version was wrong the warning did not come up in the console in Unity 2019.3.0f5, but it did show up with 2019.3.4f.

 

I'm still running into issues when building with Xcode (code signing error), but this seems to be on Apple's end (See issues with iOS 13.3.1 and non-paid developer accounts).

 

Thanks.

Log in or register to post comments