Log in or register to post comments

Marker recognition problem

April 13, 2019 - 11:19am #1

Hello,

 

I have some difficulties with marker recognition in Unity.

The thing is, The camera doesn't always recognize the marker I am using. The marker is rated 5/5 in target manager and worked fine before.

Now I have to constantly go in and out of play mode in Unity in order to make it recognize the marker randomly. 

I have also built a test app in xcode and it does the same thing there. I can't get my head around any solutions in the Unity options.

 

I have tried various different marker with different objects already.

 

If you know a solution, please let me know.

Thank you in advance.

Marker recognition problem

April 15, 2019 - 9:46am #2

Hello,

There are a few things to keep in mind if your image will not detect:

  1. Import the dataset into Unity: Assets->Import Package->Custom Package...
  2. Select the dataset in the ImageTarget prefab: ImageTarget->Image Target Behaviour (Script)->Type = Predefined, select Database and Image Target you want to be detected/tracked
  3. Be sure that when building your app, you have selected the scene with the ARCamera+ImageTarget prefab
  4. Always print the image that was uploaded to the portal to the exact same aspect ratio. Any stretching or altering of the image will cause it not to be detected. Some printers default to "stretch to fit", which can change the aspect ratio.
  5. Check the size values you are using when uploading Targets to the Vuforia Target Manager. Note there is specific language used in the dialogue box that says Vuforia uses meters as the default unit scale. Incorrect target sizes could affect either our detection/tracking algorithm, or the augmentation in that it so large that it cannot be viewed because it extends beyond the clipping plane.
  6. Review ADB logs to see if Vuforia detects and tracks the target. If the target is being tracked but the augmentation cannot be seen, this could indicate an issue with the clipping plane.

Note that the console message "trackable lost" does not indicate that something is wrong.

Can you share the target you've uploaded to the Target Manager for evaluation?

Thanks,

Vuforia Engine Support

Log in or register to post comments