Log in or register to post comments

Objects ignore ImageTargets position

December 13, 2018 - 7:04pm #1

Hello everyone,

I'm unable to solve the problem on my own: I create an AR-Book (handheld, for Android) as my final project and planned that ants move on a page. Got an ant model with a walk-animation in the asset store and found a “random movement” script. The ant-models are child of the imageTarget.

Now the problem: In the preview of the unity editor, the ants move on a wrong position and ignore the behavior of the imageTarget. It seems to be caused by the NavMesh and the NavMeshAgent. I tried to change the positions manually in the inspector, and have set the World Mode Center to “specific target”.... it doesn't work.

I also tried other scripts like https://blog.theknightsofunity.com/unity-vuforia-guide/, but my models walk on the “wrong” axis.

So, does anybody have an idea, how to fix it? Maybe I need to change an option in the inspector? Or the NavMesh? Or my script (I can post it also, if you need it)

-> Vuforia 7.5.20

-> Unity 2018.2.10f1

Thanks,

Melli

PS: I hope you understand the situation, english is not my native language :)

AttachmentSize
Image icon IMG_20181214_035112.jpg478.34 KB
Image icon Ants_Unity_WrongPosition.JPG145.33 KB
Log in or register to post comments