Log in or register to post comments

Occlusion Confusion with Transparent Planes

May 26, 2018 - 10:40am #1

Trying to achieve my animated model going "below" the "plane" and "disappearing", via occlusion management.  This at least partially works when I make the plane via a "standard" shader - i.e. you can't see the target anymore but at least the occlusion works when you are physically above it. (see attached)

When I make the plane much larger and use a Depth Mask (as I've seen in many suggestions) the occlusion works great in Unity + webcam testing, but fails on the android device the same way as you can see in this screenshot.

I have tried following any vuforia and stack overflow notes I can find, as well as the official documentation for handling occlusion.  My present setup is using the "depth mask" shader.  Most recently I tried reparenting the model to be underneath the occluder in the game-object hierarchy (another trick I saw elsewhere) but no luck.

So the Game Object layout is

/Image Target

    /Ground

        /Plane

         mesh collider + mesh renderer + DepthMask shader (or Standard, or MobileARShadow...none make a difference)

            /Model entity

              fbx + animations + script

The model starts out positioned at 0,0,0 but during the animation sequence goes "below" the Plane, which does work, just not on Android.  (actually it doesn't work on IOS either but that's because I'm on xcode 9.3 and Vuforia 7 just doesn't work there yet - entirely separate issue).

Occlusion Confusion with Transparent Planes

June 10, 2018 - 12:06am #4

Same identical problem here.... when i move object under occlusion plane ONLY on android devices.

.......ok the solution provided works for me

Occlusion Confusion with Transparent Planes

May 30, 2018 - 12:53pm #3

@dpizzle thank you so much. That worked!

Anybody else experiencing this issue, simply open up DepthMask.shader (provided by Vuforia) and change line 30

from:

ZTest LEqual

to:

ZTest Always

 

Problem solved. Build & deploy.

Occlusion Confusion with Transparent Planes

May 29, 2018 - 4:37pm #2

Change ZTest to Always in your shader.   That will most likely do it.   If you still have issues,  probably means you have multiple planes with reversed normals doing the occulusion which doesn't really work.

 

 

 

 

 

 

Log in or register to post comments