Log in or register to post comments

Problem when changing Image Targets

April 23, 2017 - 10:18am #1

Hi,

 

I am trying to create an AR app that can recognize several Image Targets and for each one of this display a different model.

I went through the initial steps (importing Vuforia 6-2-10 package and the Image Target package, setting the AR camera and the licence key, loading datasets and activating, adding the 3d model). All worked fine, the Image Target was recognized and the model displayed. 

Next I tried to introduce another ImageTarget:

Downloaded and imported a new dataset, created a new ImageTarget instance on the scene, Loaded and activated it in the AR camera settings, and gave it a different 3d model.

Here is the problem: when I run it, the first ImageTarget is recognized normally, but the second is not recognized.

Moreover: when I change the Database and the Image Target in the Image Target that works, to be any image different from the first one it never works.

Even if I delete everything on the scene and start again, this time with a different Image Target - it's not being recognized. When I switch it back to the initial image it works again.

Using Unity 5.6.0f3. I reinstalled Unity and Vuforia package, but it didn't help.

Please help!

 

V

Problem when changing Image Targets

April 26, 2017 - 10:01am #5

Thank you CieloVuelo.

These didn't seem to work, but the solution was to create a new dataset with both the tags in it

Problem when changing Image Targets

April 26, 2017 - 9:59am #4

UmarWahab wrote:

So when u set the another image target so you have to remember one thing that you must have to save one or more images in databse and download that databse again and import when you import so you realize that the previous image target dataset will be uncheck and the image is not displayed so again do the setting 

 

Thanks a lot, This solved the problem!

Makes me wonder however: does that mean I can't use more than one Dataset per scene?

Problem when changing Image Targets

April 24, 2017 - 12:14am #3

So when u set the another image target so you have to remember one thing that you must have to save one or more images in databse and download that databse again and import when you import so you realize that the previous image target dataset will be uncheck and the image is not displayed so again do the setting 

 

Problem when changing Image Targets

April 23, 2017 - 11:07am #2

I had a similar problem a while ago, have you tried moving the second instance to the left or right of the first one in the unity scene, don't 'stack the targets'?  

Make sure you drag a new prefab out of the assets not duplicate the first one in the hierarchy and that the assets Vuforia data set is activated and selected correctly on the second prefab image target.

Log in or register to post comments