Log in or register to post comments

Quad Positioning Vuforia Cloud

April 16, 2019 - 1:52pm #1

Hello, I'm changing my app, I'm making with vuforia cloud, but just as I started, I noticed something, when working with the target image in unity, I can make the Quad which will appear a video, fit just right, make it fill the whole target image, but with cloud I do not have that control, I was wondering if there's a way I can make the cloud target fill the whole target image.

Quad Positioning Vuforia Cloud

April 17, 2019 - 2:43pm #4

Hello,

pedrozocatelli wrote:

I'm having problem with 2 or more markers in the same dataset, ": Exception has been thrown by the target of an invocation. ---> UnityEngine.MissingReferenceException: The object of type 'ImageTargetBehaviour' has been destroyed but you are still trying to access it.".

This sounds like a scripting error in how you're using Vuforia APIs. Suggest you consider testing your cloud database and/or device database with the Core samples to see if the behavior is the same.

pedrozocatelli wrote:

The Cloud Image Target is deleted whenever I find a second marker.

Only a single Cloud Target can be tracked at any given time, unlike Image and/or Object Targets.

Thanks,

Vuforia Engine Support

Quad Positioning Vuforia Cloud

April 17, 2019 - 10:30am #3

I'm having problem with 2 or more markers in the same dataset, ": Exception has been thrown by the target of an invocation. ---> UnityEngine.MissingReferenceException: The object of type 'ImageTargetBehaviour' has been destroyed but you are still trying to access it.". The Cloud Image Target is deleted whenever I find a second marker.

 

The other option besides cloud, is to download the dataset containing all my markers, and create for each one a imagetarget, but I'm having trouble with it. It's really labor intensive to build the app again each time I add a new marker.

Quad Positioning Vuforia Cloud

April 17, 2019 - 9:30am #2

Hello,

This is currently a known issue with our cloud service. At this time I have no ETA for a fix.

Workaround recommendation is to store the original image (width, height) attributes - or the original aspect-ratio - as part of the metadata of the provisioned CloudReco target. Then you can use this information to correct the displayed augmentation at run time.

Thanks,

Vuforia Engine Support

Log in or register to post comments